Rockbox

Tasklist

FS#12651 - MOD files are not supposed to loop

Attached to Project: Rockbox
Opened by Fergus Duniho (fduniho) - Saturday, 21 April 2012, 12:24 GMT
Last edited by Dominik Riebeling (bluebrother) - Saturday, 21 April 2012, 14:58 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.11
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

MichaelGiacomelli (saratoga) was wrong to close my previous bug report on MOD files looping. MOD files are not supposed to loop. A MOD file contains a piece of music with a beginning and an end. Although a MOD file may have instructions for playing a certain segment more than once, the MOD file as a whole should end at some point. Computer programs that play MOD files get this right. Rockbox should too, or its ability to play MOD files is useless.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Saturday, 21 April 2012, 14:58 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Just because you don't like the behaviour doesn't make it a bug. Period.
Comment by Dominik Riebeling (bluebrother) - Saturday, 21 April 2012, 14:58 GMT
1. saratoga was not wrong in closing the previous task.
2. mod files, as implemented in Rockbox, are supposed to loop.
3. if you don't like the behaviour please discuss changing the behaviour. We have support channels for this (IRC, mailing list, forums). The tracker is *not* meant for discussing behaviour you don't like -- with that reasoning we could have literally thousands of tasks in the tracker discussion behaviour someone doesn't like.

Loading...