Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa AMSv2
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Wolfgang Dilg - 2012-05-03
Last edited by MichaelGiacomelli - 2012-05-03

FS#12661 - Problems when playing m4a files

I have prolems playing m4a files on my clip+.

1. all m4a files available at
http://metaebene.me/podcasts/ e.g.
http://meta.metaebene.me/media/mm/mm086-deutschland-wurde-heruntergeladen.m4a won’t work. They playback engine just skips the files.

2. playing files available at
http://www.apfelklatsch.de e.g.
http://files.apfelklatsch.de/podcasts_m4a/apfelklatsch_ak_032.m4a consume a enormous amount of cpu time when being played higher speed. normally I listen to them at 180%. with the dev build 5f0cb7 at this speed there apear clicks while playback.

Closed by  MichaelGiacomelli
2012-05-03 18:35
Reason for closing:  Not a Bug
Additional comments about closing:  

See comments.

MichaelGiacomelli commented on 2012-05-03 18:27

For 1), the problem is that AAC-HE files use a lot of memory, and they use even more memory when they're several hours long. For that kind of file you're probably going to be limited to about 1.5-2 hours of length before the Clip+ runs out of RAM and skips the file.

For 2), the problem is that AAC-HE files use a lot of CPU power to decode, which is fine normally, but if you run them at 2x speed they also need 2x the CPU power. Factoring in the overhead for the pitch correction and such, you'll probably be limited to about 1.5x speed if you want realtime playback (that is, no skips).

Both of these problems might in principle be fixable with enough clever optimization and memory savings, but they may not be as well. Either way, they're not bugs, just limitations of what the rather limited hardware can do with such an excessively complicated format as AAC-HE.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing