Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Recording
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Dominik Rutschmann - 2012-05-07
Last edited by MichaelGiacomelli - 2012-05-13

FS#12663 - Periodically background hissing noise in a record

Clip+ RockBox Version: 88aeef9-120505

I made a recording and now there is a soft and not very loud hiss sound in the recording. But the hissing isn’t constant. It occurs periodically and lasts for approximately one second.

I think that it may be caused by a to heavy CPU load while copying from the Ram to the internal memory, but thats just a wild guess.

It would be nice if this problem could be somehow fixed, because a clean recording is something nice to have. :)

Closed by  MichaelGiacomelli
2012-05-13 22:28
Reason for closing:  Duplicate
Additional comments about closing:  

Seems like this is covered by  FS#12291 .

MichaelGiacomelli commented on 2012-05-08 00:19

Perhaps the microphone picks up noise from the SD writes? Can you check if the hiss corresponds the frequency of disk writes (themes often have an icon that flashes during flash writes)?

Dominik Rutschmann commented on 2012-05-10 18:07

I now stumpled accidentally over an older report, where a person reports a similar or even the same problem: http://www.rockbox.org/tracker/task/12291?string=recording&project=1&type%5B0%5D=2&sev%5B0%5D=&pri%5B0%5D=&due%5B0%5D=&reported%5B0%5D=&cat%5B0%5D=&status%5B0%5D=open&percent%5B0%5D=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

He also comes to the same conclusion as I. The problem seems to be the CPU or memory writes - as you mentioned before. I also think that this problem may be eased by wiriting more frequent/constant but with less intensity (CPU usage). I expect that this work-around drains the accu faster but this compromis should be worth a clean recording. Maybe you could set this as a additional option in the recording menue, like: “Noisefree recording”.

MichaelGiacomelli commented on 2012-05-13 22:27

That does sound like the same problem. I’ll just close this task, and you can watch the original one.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing