Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#12670 : In Rockbox for Android the hardware back button exits Rockbox (instead of only going back)

Rockbox

Tasklist

FS#12670 - In Rockbox for Android the hardware back button exits Rockbox (instead of only going back)

Attached to Project: Rockbox
Opened by Dieter (dip) - Friday, 11 May 2012, 22:05 GMT
Last edited by Thomas Martitz (kugel.) - Sunday, 13 May 2012, 19:06 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Android
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I use Rockbox for Android since some time now on my Samsung Galaxy S running Android 2.3.6.

The behavior of the hardware back key has been changed in some of the last versions. Usually, when pressing the hardware back key rockbox goes up e.g. one menu level or it leaves the wps screen to the browse menu. Now when pressing the hardware back key rockbox exits the application so you can't use this key any longer to go back through the browse menus.

I use at the moment version a12b2a5 which has the old (and correct?) behavior. Version c9c1349 has e.g. the new (wrong?) behavior.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Sunday, 13 May 2012, 19:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  5f7d5b8
Comment by Thomas Martitz (kugel.) - Saturday, 12 May 2012, 11:05 GMT
I can confirm this. Need to see which commit introduced this regression.

Loading...