Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa Fuze+
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.10
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by sheldon101 - 2012-05-22
Last edited by Bilgus - 2019-08-04

FS#12682 - Sansa Fuze+ Timestretch Can't Play more than one File Then Freezes

Rockboxed Fuze+ early May. Had fixed.cfg that had timestretched enabled on. Worked OK. Then recently updated to newer version. That version fixed problem with freezing in radio
if mode wasn’t first changed to preset in context menu.

But broke playing more than one file through files. If I tried to go forward to next file, would not play but would show time as 0:00. Screen freezes Had to force reboot. And same problem again .

Eventually and I mean eventually figured out that problem was related to timestretch on. Can be reproduced either by turning timestretch on or off thru settings or thru editing config.cfg file. Config and shortcuts file attached. Using version 5f2618c-120520

To me rockbox essential for Fuze+ and podcasts/audiobooks. Horrible, horrible touch controls for FF/Rew are tamed. Ended up buying Clip Zip before discovering Rockbox. Great work.

Closed by  Bilgus
2019-08-04 20:18
Reason for closing:  Out of Date
Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

http://git.rockbox.org/?p=rockbox.git;a=commit;h=29cfd29

Was committed right after the revision you’re on. Does it solve the problem?

Can’‘t run rockbox on latest version.

Backed up will try to use backup.

after update got divide error on boot but player continued worked

Solved timestretch problem when manually changed setting and run in files mode.

Don’t use database, but tried it for testing. Did update of database. When suing database mode, files would not play but in wps there was a root root showing. Not sure if problem was caused by update of database.

However, can’t run rockbox latest version after shutdown and restart.
Rockbox start screen appears and then

*panic*
audio_reset_buffer_noalloc() EOM (655
36 > 0
bt pc:ox6003E600, sp: 0x600A9400
A: 0x6003E67C
A: 0x6003E6E4
A: 0x60018EB0
A: 0x63E56E70
A: 0x63E56E70
A: 0x63E56E70
A: 0x63E56E70
A: 0x63E56E70
A: 0x63E56E70
A: 0x63E56E70
A: 0x63E56E70
A: 0x63E56E70
A: 0x63E56E70
bt: end

Should read

after update got divide BY ZERO error on boot but player continued worked

Always do backup on update. unzipped folder from .backup and replace .rockbox with unzipped contents of .backup. Now running earlier version of May 20.

MikeS commented on 2012-05-22 20:07

Upgrade again to 29cfd29 or newer.

Good and Bad.

Upgraded to 5b9a505-120522
With this version, files work ok and timestretch works ok
But can’t play files through database. Kept getting a (root) (root) in wps and sent back to list
Don’t normally use database but initiaiized database and let it run for a while
On reboot got error and very similar list as above in 14:34 GMT -5 comment.
So I deleted 3 files from .rockbox
database_0.tcd
database_idx.tcd
database.tmp.tcd and player doesn’t abort and works fine through files

then did another install to see if database files created if they don’t exist . The 3 files were not created and player works with files OK.
I’ll set database.ignore file to ignore everything

MikeS commented on 2012-05-23 07:59

Strange things are afoot lately. It seem like there is random corruption of some sort going on and some changes just made it more obvious.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing