Rockbox

Tasklist

FS#12702 - playlist catalgoue silently fails to save files with < and > characters

Attached to Project: Rockbox
Opened by drewbenn (drewbenn) - Tuesday, 19 June 2012, 18:59 GMT
Task Type Bugs
Category User Interface
Status Unconfirmed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.11
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

I'm running Rockbox 3.11.2 on a Sansa Clip+.
I followed these steps:
- go to the Main Menu
- Files
- long press on <microSD1>
- Playlist Catalogue
- Add to New Playlist
I tried to save the playlist with a long press of the select button (not sure of the button's actual name; it is the button in the middle of the 4-way controller and the one that is usually used to select the highlighted option). I was returned to the Files menu. The playlist did not get saved, and there was no error explaining why.

As a result, I spent a long time assuming that long press of select was a "cancel" action, and tried short and long presses of every other button trying to save the playlist.

Workaround: instead of accepting the suggested filename, remove the "<" and ">" characters from the auto-entered filename ("/Playlists/<microSD1>.m3u8") to be able to save the playlist.

Suggested fixes: The filename suggested by Rockbox should not include "<", ">", or other un-saveable characters. In addition, if the user tries to save a file with invalid characters, a warning or error message should be posted (like the "Cancelled" message that briefly pops up when the power button is pressed to exit from the set-filename screen).
This task depends upon

Comment by Chris Jordan (chrisjj) - Friday, 06 January 2017, 13:35 GMT
This bug is present still, on current dev build.

Loading...