Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by Brian van den Berg - 2012-06-23
Last edited by MichaelGiacomelli - 2016-08-28

FS#12705 - Undefined instru bt pc: 30800000, Clip Zip Drivers Problem

daily build: d245997

Undefined instru
bt pc: 30800000,
I plug my Clip Zip into the PC(Windows 7) For the first time it tries to install the drivers and it fails. After plugging it out this happens. It feels like my mp3’s screen is too small for the error.

Closed by  MichaelGiacomelli
2016-08-28 20:14
Reason for closing:  Out of Date
Additional comments about closing:  

Closing bug reports for the old USB stack now that we have the new one committed and stable. Most likely these problems are fixed now.

Bertrik Sikken commented on 2012-06-24 11:03

Can you reliably reproduce this problem, or was it a one time incident?

Thomas Martitz commented on 2012-06-25 07:29

Isn’t 0×3080000 the start of the RAM? Broken entry point/reset vector?

Perhaps the download was just corrupted; however the bootloader _should_ detect this with the checksum check (it’s not 100% safe though).

EDIT: Ah no, it should be start of IRAM. So it seems coping icode from the binary to IRAM failed somehow.

Christoph commented on 2012-07-16 13:39

I have the same problem! The display seems to be to small. How I can turn the player off? One settings I changed was the “Load to RAM” to “yes”.
Hopefully somebody can help!

Best regards
mobman

btittelbach commented on 2012-07-28 12:04

confirming bug on Linux and rockbox sansa-clip-zip daily build version 9a84bcf-120727 from 2012-07-28

As soon as the player is connected to the pc and enters mass-storage-mode, instead of the usb-plug-logo, the device crashes and the display reads
“Undefined instru”

Behaviour seems independant from any settings and just appeared after updating to latest daily build. Bug is present even in daily build from 2012-07-01 and likely appeared somewhen mid June.

regards,
bt

Oscar commented on 2012-08-18 08:56

Just seen this after the SansaAMS wikipage update. I get something similar on my clipzip (build 2f1da04-120627 - i.e. late June as the above comment suggests).

USB works almost perfectly on my Linux box, however, after safely removing the device, on unplugging it it occasionally locks up with an error message (can’t read it with my theme, as it is black text on almost black background). When this happens I usually need to shut down the player by holding in the power button for around 20s. Anyway, any music transferred seems to be OK after these lock-ups, so I’d personally consider it a minor nuisance for now, and won’t bother to upgrade for the time being. I don’t get it crashing on plugging in though, only unplugging, and even then only sometimes.

Hope this helps,
Oscar

A B commented on 2013-11-18 17:59

I can see that problem on my new SanDisk Sansa Clip+ too (both with 3.13-STABLE as well as with a month old DEVEL), the only way I am able to transfer files is to boot to original firmware. Is there a way I can help with this issue? Thought I an not able to debug it on source code level I might be able to find other relevant info from that device. Let me know how can I help.

Brian van den Berg commented on 2013-11-19 09:51

Ok. This ONLY happens the first time the drivers are tried to be installed. Hard-reset is needed, after that drivers load normally and it works forever on that PC. However, this happens everytime i try to plug it in in a new PC. Hope that explains it well.

Robert commented on 2014-08-11 15:15

This happened to my SanDisk Sansa Clip Zip as well today. I can confirm it happened on the first USB plug in on a new machine and then removing the plug caused the undefined instruction. Hard rebooting the device was required and after plugging it in again the drivers installed correctly

Rock Box Version 3.13
SanDisk Sansa Clip Zip (DMX22-004G-A57K)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing