Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System Sansa AMSv1
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Autofils - 2012-07-13
Last edited by speachy - 2021-05-19

FS#12714 - Sansa Fuze V1 USB Fails on daily build (ad46064-120710)

I upgraded my Sansa Fuze V1 (AMSV1) from the current stable release 3.11.2 to Daily build (ad46064-120710). With Rockbox powered on, any attempt to connect USB to my WinXP fails. The USB icon is displayed briefly, followed immediately by the white screen - Undefined Instruction at 0000003C. This is repeatable. Recovery is via a power down.

Note: the USB connection works fine with the current stable release 3.11.2 and this is the first daily build I have tried,

Closed by  speachy
2021-05-19 21:03
Reason for closing:  Out of Date
Additional comments about closing:  

AFAICT this has been long resolved, by bumping the USB stack size a smidge.

I’ve seen the same symptom (undefined instruction, 0000003C) on my sansa clip zip (which is an AMSv2 player), although I think it didn’t happen immediately.

Theres a lot more information about this bug report here: http://anythingbutipod.com/forum/showpost.php?p=616375&postcount=9

Sounds like a general stability problem with various builds on the Fuze v1, so I suspect its the same problem as  FS#12184 .

Today I did a clean install of Daily Build (ad46064-1207-10) on my Sansa Fuzev1, by removing the existing .rockbox folder and then installing the daily build as a “clean install”.
I restored my config and sound settings, installed the 3.11.2 font package and the kissv2 theme that I was using before and I now cannot duplicate the usb problem  FS#12714 .
The usb function on my Sansa Fuzev1 with daily build (ad46064-120710) now works correctly, after this “Clean Install :)

Previously I connected the Fuze usb to a 4 port hub and when I noticed some random usb disconnect and then quick reconnects during a usb session, I removed the 4 port usb hub and plugged the Fuze into a dedicated PC USB hub. The “clean install " today used the dedicated PC USB port, whereas the 4 port hub was used when I reported  FS#12714  and I suspect the 4 port hub caused some file corruption that affected the USB function.

Perhaps the Rockbox manual should recommend a direct PC USB connection, not a 4 port hub?

Based on this “clean install” result, I think you can close this report.
… Carson

I can reproduce this with the screendump feature. I can also manage to avoid it by increasing the USB stack size. So something seems to be heavy on the usb thread stack (not screendump) causing this during normal operation

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing