Rockbox

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Sansa AMSv2
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Oliver Matthews - 2012-10-03

FS#12760 - FLAC / Embedded cue sheet skipping issues.

This is a reopen of issue #1 of  bug 7354  (http://www.rockbox.org/tracker/task/7354)

SETUP:
HW: sansa clip+
SW: 8687b98-121001

CD's ripped as wav/cue with EAC 1.0b3 then converted to FLAC w/embedded cue with cuetools 2.1.4; used accuraterip to confirm good rip.

EXPECTED BEHAVIOUR:

loading a flac w/embedded cue would display markers within the track and allow forward/back skipping within the track.

ISSUE:
Some tracks I am unable skip to using next/back or rewind to the start of using back.
If I listen to the whole preceeding track then the display updates correctly as it goes.

I've tested this with a handful of CDs, and given the previous bug, this appears to be a general issue with flacs/embedded cuefiles.

Oliver Matthews commented on 2012-10-03 13:50

btw, cuesheets are embedded as a vorbis comment via this means rather than a cuesheet tag (presumably to allow track names).

I have tried adjusting the offset for an offending song by +1s and this fixed it, so the previous submitters suspicion that it is having issues with specific points on a flac seems plausible.

Oliver Matthews commented on 2012-10-03 14:40

Further investigation: a .01s adjustment (the smallest allowed) is (on my test album), enough to fix the problem.

editing the tag of one of the working ones to put it back to the original non-working value does stop it working again.

Oliver Matthews commented on 2012-10-03 14:52

Aha. Stripping the seektable from the flac also removed the problem. Possibly a problem with seektable entry / cuesheet index collisions?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing