Rockbox

Tasklist

FS#12774 - Files are not correctly sorted if the track number is 100 or more.

Attached to Project: Rockbox
Opened by Tsuda Kageyu (TsudaKkageyu) - Monday, 22 October 2012, 19:20 GMT
Last edited by Thomas Martitz (kugel.) - Tuesday, 18 February 2014, 07:35 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.11
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

When browsing the database, files are not correctly sorted by track number if some track numbers are 100 or more.
Files are sorted like this:
10
100
101
...
109
11
110
111
This task depends upon

Closed by  Thomas Martitz (kugel.)
Tuesday, 18 February 2014, 07:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  84c7d61
Comment by Hayden Pearce (St.) - Wednesday, 30 January 2013, 10:01 GMT
Not a bug, this is "natural order numeric sorting".

see:
http://www.naturalordersort.org/


[Saint]
Comment by Zian Choy (Zian) - Friday, 22 November 2013, 06:47 GMT
Even so, it doesn't behave the way users expect it to. Having a good explanation doesn't help too much from that perspective.
Comment by Dominik Riebeling (bluebrother) - Monday, 17 February 2014, 19:35 GMT
This is neither a bug nor a "natural sorting" issue. It's a formatting issue in the database. See http://www.rockbox.org/irc/log-20140217#20:23:18

Loading...