Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.11
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Zian - 2012-11-10
Last edited by saratoga - 2013-06-09

FS#12780 - Sansa Clip+ Skips To Next Track While Playing a WMA File

Context:

Portable Media Player:
- Sansa Clip+ (Black/4GB)
- Rockbox Version 3.11.2

Audio File That Gets Skipped:
- Encoded with Expression Encoder 4 SP2
- Mode: WMA (VBR Quality)
- Channels: Stereo
- Quality: 25
- Sample Rate: 44.1 kHz
- Bits Per Sample: 16
- 46 minutes and 38 seconds long

Every time I play the track that gets skipped, the track plays for a little bit (the duration of this “little bit” never changes) and then Rockbox jumps to the next track. Other tracks in the album are encoded with the same settings using the same encoding software. The other tracks play without any trouble.

I have tried searching the forums for similar issues but I came up empty. I also tried re-importing the file using Windows Media Player version 12.0.7601.17514 and rebooting the portable media player to no avail.

The problem has been confirmed by playing the file on my Clip+ while someone else was listening.

I first discussed the issue at http://forums.rockbox.org/index.php?topic=38862.

As a result of the forum post, I uninstalled rockbox using http://forums.rockbox.org/index.php/topic,30183.0.html.

Then, I tried accessing files and saw that the album’s tracks were showing up as “Á” as both their album name, artist name, and genre. Verifying metadata with Mp3Tag shows no problems.

Next, I formatted the player using the player and then reloaded the tracks.

Finally, I tried playing the tracks and the player skipped instantly forward without playing any of the desired track.

One of the files that trigger the bug can be downloaded from https://skydrive.live.com/redir?resid=87EA02230C32BE40!669&authkey=!AGcg2MV4i7uP9RU. You can also contact me to get the file if the file is no longer online.

Closed by  saratoga
2013-06-09 18:43
Reason for closing:  Out of Date
Additional comments about closing:  

Dead link in the OP, and the second file in the task decodes correctly with the current build. If either of these bugs can be reproduced with the current build, post a new task with a link to the file.

I am having the same issue on my Sansa Fuze+.

example file: https://sites.google.com/site/rchrdcrg/Doomed_HD.wma source: https://sites.google.com/site/rchrdcrg/doomed

MikeS commented on 2013-02-07 18:47

Are the tracks marked "(ERR)" in the current playlist? If so, the metadata parser thinks it's bad. If not, something about it is making the codec terminate too soon.

No, their metadata parses correctly. Rockbox even displays the full, correct duration of the song, but decoding seemingly aborts part of the way through. Attempting to seek past the "stop point" will cause the next file to begin playing.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing