Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Settings
  • Assigned To No-one
  • Operating System Sansa Fuze+
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.12
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Jean-Louis Biasini - 2012-11-21
Last edited by Moshe Piekarski - 2020-07-27

FS#12783 - Fuze+ : Clock's value doesn't get save anymore

A very rare issue but confirmed by at least 3 different users:
The clock get resetted “by itself” to some default value (12:00 if I remember correctly) Setting a new time works but the clock get resetted again upon each reboot.
Booting into original firmware and setting the time there solves the issue.

Closed by  Moshe Piekarski
2020-07-27 21:10
Reason for closing:  Fixed
Bertrik Sikken commented on 2012-11-23 15:57

Do you know since when this happens? I made some changes in May 2012, to simplify clock/calendar calculations for various targets.
Also, does just the clock time reset, or does it also affect the date?

Jean-Louis Biasini commented on 2012-11-23 18:58

From what I remember it The date also resetted but i’m not sureā€¦ I don’t thing this is related to your changes because there’s been people complaining about clock problem from the beginning of the port (at list one or two) but the never made it to post a bug, then it happens to me a few mouth ago (can’t recall exactly when). And someone just post a few days ago on the forum.

Tyler Johnson commented on 2012-12-29 03:02

I think I’ve found the cause of this issue. If you connect the device to a “new” computer, that’s what resets the clock. I should mention, when I say new, I’m really referring to a computer that has never been connected to the particular Fuze+ whose clock was resetted, regardless of how new the machine really is. This has also been reported on the Sansa forums by users who have never used Rockbox, so it’s probably not be Rockbox-related. I suspect that this happens for DRM reasons, where users might only be granted the rights to play a song or video for a limited period of time. I can’t be sure, though, since I prefer not to buy anything crippled by DefectiveRightsMismanagement/DRM.

Personally, I’ve never been able to get it to display the right time once a “new” computer is connected, regardless of which firmware I use to correct the time. However, one workaround has been pointed out on the Sansa forums, which has worked many times for me. Simply connect the device, in MTP mode (again,it must be in MTP mode. I cant stress this enough), to a Windows-based computer with Windows Media Player version 10 or higher. Needless to say, MTP mode requires you to use the ORIGINAL firmware, as it’s unsupported by Rockbox. Start WMP, and let it “update” the clock. When you disconnect, the clock will still show the wrong time, but when you fix it, (at this point, it makes no difference which firmware you use), it will stay fixed until you connect it to another “new” computer.

Moshe Piekarski commented on 2020-07-02 02:12

I have run across this issue without connecting to a computer.
The workaround of setting the time from the OF seems to work

Moshe Piekarski commented on 2020-07-08 07:54

prospective fix in gerrit g#2469 requires testing

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing