FS#12790 - Remaining time of track shows incorrectly

Attached to Project: Rockbox
Opened by Simon Bookman (SBookman) - Thursday, 13 December 2012, 08:19 GMT
Last edited by MichaelGiacomelli (saratoga) - Thursday, 13 December 2012, 16:45 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



May I refer you to

where my case for supposing if not a bug, then at least a strangeness, is apparent.

I can supply you with these files if you so require.


Rockbox version: d119fb1-121202
Sansa Clip Zip
   Test3.mp3 (451.5 KiB)
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Thursday, 13 December 2012, 16:45 GMT
Reason for closing:  Not a Bug
Comment by MichaelGiacomelli (saratoga) - Thursday, 13 December 2012, 16:45 GMT
Well, foobar2000 can't even fully decode the file because its corrupt. So that's not a good start :)

Most likely someone just cut the end of the file off without updating the header. Or they calculated the length wrong and wrote it in the header. Rewriting the VBR header in foobar fixes the problem.