Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Sansa AMSv2
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.12
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by ConiKost - 2013-03-11
Last edited by speachy - 2021-05-12

FS#12840 - Lock/Unlock-Message does not disappear completely

Hi,
I am using a Sansa Clip Zip with Rockbox 3.13.
I’ve noticed, when I lock or unlock the device, the message, which indicates the current state, does not disappear completely. Its still there.

Cheers,
Conrad

Closed by  speachy
2021-05-12 21:23
Reason for closing:  Out of Date
Additional comments about closing:  

Should be completely fixed with the recent viewport rewrite.

This I had also on 3.12,but it doesn't bother me!

I've had this problem on a sansa fuze plus but only using radio and this patch http://gerrit.rockbox.org/r/#/c/421/
Also this only happens sometimes.

I can confirm the bug for Samsung Clip Zip for 3.13

IMHO it looks like a problem with refreshing the canvas area. If you visit the menu, the label disappears again and everything is fine. Not sure if this is related to a special theme or a generic bug :/

A quick & dirty workaround is to edit the skin to draw an empty viewport over the label area before drawing anything else, something like this:

# Load bitmap files

# draw a black-filled viewport to clean up garbage after popups
%V(0,40,96,30,-)%Vb(000000)

# draw the rest of the skin

The theme I'm using has no backdrop image and the background is solid black. YMMV if you have an image as a backdrop.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing