Rockbox

Tasklist

FS#12894 - Text scrolling stops working after a few seconds/minutes

Attached to Project: Rockbox
Opened by Ronald Malbosc (Chiyo-chan) - Monday, 02 September 2013, 08:27 GMT
Last edited by Thomas Martitz (kugel.) - Sunday, 12 January 2014, 20:30 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

The bug is present in the latest dev build (Sept 1st).
I started facing this bug quite a long time ago (I can't remember precisely).

I don't really know what's triggering the bug.

Just after the player boot, the txt scrolls correctly, but after just a few seconds (or sometimes minutes).
It seems to be related to screen refreshes, but I'm not 100% sure.

Problem is present both on main screen and lcd remote screen.
Problem is present both on WPS and all the menu.
Resetting the settings doesn't correct the problem.
I can't seem to reproduce the bug on the latest h300 simulator.

TIA,
Ronald
This task depends upon

Closed by  Thomas Martitz (kugel.)
Sunday, 12 January 2014, 20:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  Sorry for the delay. Almost forgot about this. Fixed in eafc701
Comment by Ronald Malbosc (Chiyo-chan) - Monday, 02 September 2013, 08:28 GMT
Correcntion, the bug is also present on the simulator, it just took its time to happen ^^
Comment by Ronald Malbosc (Chiyo-chan) - Tuesday, 26 November 2013, 18:04 GMT
The problem is still here in today's build.
Comment by Thomas Martitz (kugel.) - Monday, 23 December 2013, 19:27 GMT
Can you try the latest build again?
Comment by Ronald Malbosc (Chiyo-chan) - Thursday, 26 December 2013, 09:43 GMT
I don't have my h300 at hand, but I tried with the simulator, and it seems to have work correctly.
I'll confirm that on monday.
Thanks
Comment by Ronald Malbosc (Chiyo-chan) - Monday, 30 December 2013, 13:22 GMT
Unfortunately, the problem is still here.
I don't know if that can help, but I realized that even before your fix, when I didn't use the lcd remote, the scrolling on the main lcd was ok (it's not ok when the remote lcd is used).

Hope this helps...
Comment by Thomas Martitz (kugel.) - Thursday, 02 January 2014, 09:34 GMT
Does this patch fix anything?
Comment by Ronald Malbosc (Chiyo-chan) - Thursday, 02 January 2014, 09:43 GMT
Sorry, I don't have a compilation environment at hand.
Comment by Thomas Martitz (kugel.) - Thursday, 02 January 2014, 10:45 GMT Comment by Ronald Malbosc (Chiyo-chan) - Thursday, 02 January 2014, 11:06 GMT
7-zip says archive is corrupted (downloaded it twice) :(
Comment by Thomas Martitz (kugel.) - Thursday, 02 January 2014, 11:08 GMT
It's a zip (created with zip command line tool) and works for me. Let's check the md5sum: 9f6049e27ac224dd44cb67f935a69bfd
Comment by Ronald Malbosc (Chiyo-chan) - Thursday, 02 January 2014, 11:10 GMT
I have a md5 starting with 754c721
Comment by Thomas Martitz (kugel.) - Thursday, 02 January 2014, 11:11 GMT
This means your download is corrupted. I can download the file and the md5sum matches the original file
Comment by Ronald Malbosc (Chiyo-chan) - Thursday, 02 January 2014, 12:50 GMT
The 3rd download was ok...
This patch seems to correct the bug.
I've only let it play 4-5 songs, I'll confirm after going back from work.

Thanks
Comment by Ronald Malbosc (Chiyo-chan) - Friday, 03 January 2014, 10:07 GMT
Hi,

I confirm this new patch corrected the bug!

Thanks!
Comment by Thomas Martitz (kugel.) - Friday, 03 January 2014, 10:31 GMT
Thanks, I will push this fix to git master in a few hours.

Loading...