Rockbox

Tasklist

FS#12922 - Opus playback failure with album art

Attached to Project: Rockbox
Opened by Hunter Chandler (wohonajax) - Monday, 23 December 2013, 22:59 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 12 January 2014, 20:54 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa Clip Zip
Severity Low
Priority Normal
Reported Version Release 3.13
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

When attempting to play an Opus file on my Clip Zip, the system will sometimes either freeze or give an error, like this:

Data abort at 30
FSR 0x8
(domain 0, fault
address 0xFF780
pc:3004C8F4 sp:3
bt end

Whether it freezes or gives an error appears to be random. The address also appears to be random. I fixed the issue by removing album art from the files that were giving me problems. The strange thing is, though, that I have other opus files with album art, and they play without issue.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 12 January 2014, 20:54 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Probably fixed by one of the upstream opus syncs.
Comment by MichaelGiacomelli (saratoga) - Tuesday, 24 December 2013, 05:54 GMT
Does this happen with the current build?
Comment by Hunter Chandler (wohonajax) - Tuesday, 24 December 2013, 11:11 GMT
Yes, version 3.13
Comment by Thomas Martitz (kugel.) - Wednesday, 25 December 2013, 17:00 GMT
He refered to development builds from http://build.rockbox.org/
Comment by Hunter Chandler (wohonajax) - Wednesday, 25 December 2013, 17:44 GMT
In that case, no. I'm using the stable build. Should I try the latest development build and see if it works?
Comment by Hunter Chandler (wohonajax) - Wednesday, 25 December 2013, 20:57 GMT
Alright, I've tested the files on developer build 8566cd7 and the issue seems to be gone. What could have been the cause of this? As I said, I have other Opus files with album art that played fine.

Loading...