Rockbox

Tasklist

FS#12938 - Simulators don't work under windows.

Attached to Project: Rockbox
Opened by Szymon Dziok (b0hoon) - Friday, 17 January 2014, 08:22 GMT
Last edited by Thomas Martitz (kugel.) - Sunday, 26 January 2014, 13:43 GMT
Task Type Bugs
Category Simulator
Status Closed
Assigned To Thomas Martitz (kugel.)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Compiled on version 335d708 simulators dont work under windows.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Sunday, 26 January 2014, 13:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  37be80a
Comment by Thomas Martitz (kugel.) - Friday, 17 January 2014, 09:00 GMT
Did you compile yourself or did you take one of rasher's prebuild sims (I can reproduce the problem with rasher's under wine)? FWIW, why do you assign this to me, do you have an evidence that I caused it?
Comment by Thomas Martitz (kugel.) - Friday, 17 January 2014, 10:24 GMT
I just pushed some win32-related changes, one of them could potentially fix the problem. Can you re-test? A sim compiled with i686-w64-mingw32- now works for me.
Comment by Szymon Dziok (b0hoon) - Friday, 17 January 2014, 10:38 GMT
> FWIW, why do you assign this to me, do you have an evidence that I caused it?

Well... i assumed that you are the right person, who can fix this (not because i thought you did it), since you have done a big work on the app stuff. Other than that, i have no excuse - sorry, you're right.

> Did you compile yourself or did you take one of rasher's prebuild sims

I took it from the web site.

I'll test it later, sure.
Comment by Thomas Martitz (kugel.) - Friday, 17 January 2014, 10:41 GMT
These are only rebuilt once per day. I don't have access to his toolchain right now so I can only test with what arch provides.
Comment by Thomas Martitz (kugel.) - Friday, 17 January 2014, 10:47 GMT
Oh, and don't worry, I didn't take it as an offense. I just wondered if you had a certain change/commit in mind.
Comment by Szymon Dziok (b0hoon) - Friday, 17 January 2014, 23:00 GMT
Unfortunately i can't test it on my Debian due to some SDL errors. Automatically selected arch: x86. So we'll see tomorrow.

Thanks for a fix all of this stuff through past weeks. You are doing an outstanding job.
I think that Rockbox is getting closer to the condition which it had in the past - thanks to you. And that's cool :)


Comment by Thomas Martitz (kugel.) - Saturday, 18 January 2014, 13:13 GMT
rasher's sims still don't work. Difficult for me to find what the problem is because the ones I build on my machine work fine.
Comment by Szymon Dziok (b0hoon) - Tuesday, 21 January 2014, 23:21 GMT
Hi Thomas.

After fighting with a setup the mingw32 with the proper SDL, finally i was able to compile the sim and i can reproduce it, whoah...

Revision which broke it: c23ce62: fonts: Do not unload completely on USB.

Architecture is x86.
Comment by Thomas Martitz (kugel.) - Tuesday, 21 January 2014, 23:27 GMT
Thanks for that. I wonder why it doesnt show when I compile with mingw-w64.

Can you see anything obviously wrong in that commit?
Comment by Szymon Dziok (b0hoon) - Tuesday, 21 January 2014, 23:55 GMT
I will look at it tomorrow.
Comment by Thomas Martitz (kugel.) - Sunday, 26 January 2014, 13:03 GMT
Should be fixed by 37be80a. Please confirm.
Comment by Szymon Dziok (b0hoon) - Sunday, 26 January 2014, 13:42 GMT
Yeah, it works for me now in Win7 and under Wine. So i guess it's fixed. Thanks! :)

Loading...