Rockbox

Tasklist

FS#12939 - clip+ usb connection problem

Attached to Project: Rockbox
Opened by Baranko (mesb) - Saturday, 18 January 2014, 19:05 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 28 August 2016, 20:07 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System Sansa Clip+
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi.
Dev. build 644d9ea-140115
Problem with usb connections.

Clip+ 4gb version, microsd transcend 32gb 10 class, formatted to fat32 and works without any issue in cardreader too.
When i use sandisk firmware all goes fine in any cases.

On 3.13 and dev build i have:

Reproducable:
When i copy files in internal memory (ejected sd card) onmy win7 book, looks like no any errors.
When i copy files in sd card that inserted in player, only approx 1,5 gb i can write on sansa and it disconnects (win 7 drive names becomes inaccesible) or hang. Need to be restarted by power button.


Also there is problem with usb hub between pc and sansa:
If i turn off device and connect it via dlink dub-h7 usb hub i get this:
Jan 15 20:43:25 puma kernel: usb 4-2.2: new high-speed USB device number 19 using ehci-pci
Jan 15 20:43:26 puma kernel: hub 4-2:1.0: cannot reset port 2 (err = -71)
Jan 15 20:43:26 puma kernel: hub 4-2:1.0: cannot reset port 2 (err = -71)
Jan 15 20:43:26 puma kernel: hub 4-2:1.0: cannot reset port 2 (err = -71)
Jan 15 20:43:26 puma kernel: hub 4-2:1.0: cannot reset port 2 (err = -71)
Jan 15 20:43:26 puma kernel: hub 4-2:1.0: cannot reset port 2 (err = -71)
Jan 15 20:43:26 puma kernel: hub 4-2:1.0: Cannot enable port 2. Maybe the USB cable is bad?
Jan 15 20:43:26 puma kernel: hub 4-2:1.0: cannot disable port 2 (err = -71)
Jan 15 20:43:26 puma kernel: hub 4-2:1.0: cannot reset port 2 (err = -71)

If i connect device while sansa is on it's connect ok.
In this case sansa just goes into home screen no any hang or something.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 28 August 2016, 20:07 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Closing bug reports for the old USB stack now that we have the new one committed and stable. Most likely these problems are fixed now.
Comment by Baranko (mesb) - Sunday, 19 January 2014, 09:43 GMT
Rev 63cfbe0.
Guys, there is some strange detected:

If i connect sansa to linux while turned on, it connects at high speed:
Jan 19 13:35:44 puma kernel: usb 4-6: new high-speed USB device number 14 using ehci-pci
Jan 19 13:35:44 puma kernel: usb 4-6: New USB device found, idVendor=0781, idProduct=74d1
Jan 19 13:35:44 puma kernel: usb 4-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 19 13:35:44 puma mtp-probe[17358]: checking bus 4, device 14: "/sys/devices/pci0000:00/0000:00:10.3/usb4/4-6"
Jan 19 13:35:44 puma mtp-probe[17358]: bus: 4, device: 14 was not an MTP device
Jan 19 13:35:44 puma kernel: usb 4-6: Product: Rockbox media player
Jan 19 13:35:44 puma kernel: usb 4-6: Manufacturer: Rockbox.org
Jan 19 13:35:44 puma kernel: usb 4-6: SerialNumber: 1A8C363060CFEFE8C00000000
Jan 19 13:35:44 puma kernel: usb-storage 4-6:1.0: USB Mass Storage device detected
Jan 19 13:35:44 puma kernel: scsi6 : usb-storage 4-6:1.0
Jan 19 13:35:45 puma kernel: scsi 6:0:0:0: Direct-Access Rockbox Internal Storage 0.00 PQ: 0 ANSI: 4
Jan 19 13:35:45 puma kernel: scsi 6:0:0:1: Direct-Access Rockbox SD Card Slot 0.00 PQ: 0 ANSI: 4
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] 7683072 512-byte logical blocks: (3.93 GB/3.66 GiB)
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] Write Protect is off
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] Mode Sense: 0b 00 00 08
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] 7882752 512-byte logical blocks: (4.03 GB/3.75 GiB)
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] No Caching mode page found
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] Assuming drive cache: write through
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] Write Protect is off
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] Mode Sense: 0b 00 00 08
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] No Caching mode page found
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] Assuming drive cache: write through
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] No Caching mode page found
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] Assuming drive cache: write through
Jan 19 13:35:45 puma kernel: sdb:
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] No Caching mode page found
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] Assuming drive cache: write through
Jan 19 13:35:45 puma kernel: sdc: sdc1
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] No Caching mode page found
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] Assuming drive cache: write through
Jan 19 13:35:45 puma kernel: sd 6:0:0:0: [sdb] Attached SCSI removable disk
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] No Caching mode page found
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] Assuming drive cache: write through
Jan 19 13:35:45 puma kernel: sd 6:0:0:1: [sdc] Attached SCSI removable disk




But, if i connect it while turned off, it starts as usb 1.0 just full speed:
Jan 19 13:36:33 puma kernel: usb 4-6: new high-speed USB device number 15 using ehci-pci
Jan 19 13:36:34 puma kernel: usb 3-2: new full-speed USB device number 3 using uhci_hcd
Jan 19 13:36:34 puma kernel: usb 3-2: not running at top speed; connect to a high speed hub
Jan 19 13:36:34 puma kernel: usb 3-2: New USB device found, idVendor=0781, idProduct=74d1
Jan 19 13:36:34 puma kernel: usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 19 13:36:34 puma kernel: usb 3-2: Product: Rockbox media player
Jan 19 13:36:34 puma kernel: usb 3-2: Manufacturer: Rockbox.org
Jan 19 13:36:34 puma kernel: usb 3-2: SerialNumber: 1A8C363060CFEFE8C00000000
Jan 19 13:36:34 puma kernel: usb-storage 3-2:1.0: USB Mass Storage device detected
Jan 19 13:36:34 puma kernel: scsi7 : usb-storage 3-2:1.0
Jan 19 13:36:34 puma mtp-probe[17434]: checking bus 3, device 3: "/sys/devices/pci0000:00/0000:00:10.2/usb3/3-2"
Jan 19 13:36:34 puma mtp-probe[17434]: bus: 3, device: 3 was not an MTP device
Jan 19 13:36:35 puma kernel: scsi 7:0:0:0: Direct-Access Rockbox Internal Storage 0.00 PQ: 0 ANSI: 4
Jan 19 13:36:35 puma kernel: scsi 7:0:0:1: Direct-Access Rockbox SD Card Slot 0.00 PQ: 0 ANSI: 4
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] 7683072 512-byte logical blocks: (3.93 GB/3.66 GiB)
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] Write Protect is off
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] Mode Sense: 0b 00 00 08
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] 7882752 512-byte logical blocks: (4.03 GB/3.75 GiB)
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] No Caching mode page found
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write through
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] Write Protect is off
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] Mode Sense: 0b 00 00 08
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] No Caching mode page found
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] Assuming drive cache: write through
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] No Caching mode page found
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write through
Jan 19 13:36:35 puma kernel: sdb:
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] No Caching mode page found
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] Assuming drive cache: write through
Jan 19 13:36:35 puma kernel: sdc: sdc1
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] No Caching mode page found
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write through
Jan 19 13:36:35 puma kernel: sd 7:0:0:0: [sdb] Attached SCSI removable disk
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] No Caching mode page found
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] Assuming drive cache: write through
Jan 19 13:36:35 puma kernel: sd 7:0:0:1: [sdc] Attached SCSI removable disk

Maybe this is problem with usb hub that i describe?
And data transfers fine while low speed.

Win7 just don't care, all fine with it.







Also Kugel on irc ask me test with different sd cards my problem, i found transcend 4gb 6 class.
Almsot 1 hour of copy data, no problems at all.
So looks like he said: Card specific with driver.
Comment by Baranko (mesb) - Sunday, 19 January 2014, 14:02 GMT
Copy from linux box to internal memory of clip+.
Card 32gb 10 class was inserted and mounted, but not used.


Jan 19 17:51:27 puma kernel: usb 4-6: new high-speed USB device number 18 using ehci-pci
Jan 19 17:51:27 puma kernel: usb 4-6: New USB device found, idVendor=0781, idProduct=74d1
Jan 19 17:51:28 puma kernel: usb 4-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 19 17:51:28 puma mtp-probe[27722]: checking bus 4, device 18: "/sys/devices/pci0000:00/0000:00:10.3/usb4/4-6"
Jan 19 17:51:28 puma mtp-probe[27722]: bus: 4, device: 18 was not an MTP device
Jan 19 17:51:28 puma kernel: usb 4-6: Product: Rockbox media player
Jan 19 17:51:28 puma kernel: usb 4-6: Manufacturer: Rockbox.org
Jan 19 17:51:28 puma kernel: usb 4-6: SerialNumber: 1A8C363060CFEFE8C00000000
Jan 19 17:51:28 puma kernel: usb-storage 4-6:1.0: USB Mass Storage device detected
Jan 19 17:51:28 puma kernel: scsi10 : usb-storage 4-6:1.0
Jan 19 17:51:28 puma kernel: scsi 10:0:0:0: Direct-Access Rockbox Internal Storage 0.00 PQ: 0 ANSI: 4
Jan 19 17:51:29 puma kernel: scsi 10:0:0:1: Direct-Access Rockbox SD Card Slot 0.00 PQ: 0 ANSI: 4
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] 7683072 512-byte logical blocks: (3.93 GB/3.66 GiB)
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] Write Protect is off
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] Mode Sense: 0b 00 00 08
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] 61863936 512-byte logical blocks: (31.6 GB/29.4 GiB)
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] No Caching mode page found
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] Assuming drive cache: write through
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] Write Protect is off
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] Mode Sense: 0b 00 00 08
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] No Caching mode page found
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] Assuming drive cache: write through
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] No Caching mode page found
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] Assuming drive cache: write through
Jan 19 17:51:29 puma kernel: sdb:
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] No Caching mode page found
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] Assuming drive cache: write through
Jan 19 17:51:29 puma kernel: sdc: sdc1
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] No Caching mode page found
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] Assuming drive cache: write through
Jan 19 17:51:29 puma kernel: sd 10:0:0:0: [sdb] Attached SCSI removable disk
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] No Caching mode page found
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] Assuming drive cache: write through
Jan 19 17:51:29 puma kernel: sd 10:0:0:1: [sdc] Attached SCSI removable disk
Jan 19 17:51:29 puma udisksd[2218]: Mounted /dev/sdb at /run/media/mesb/0123-4567 on behalf of uid 500
Jan 19 17:51:29 puma udisksd[2218]: Mounted /dev/sdc1 at /run/media/mesb/SD on behalf of uid 500
Jan 19 17:55:00 puma kernel: usb 4-6: reset high-speed USB device number 18 using ehci-pci
Jan 19 17:55:15 puma kernel: usb 4-6: device descriptor read/64, error -110
Jan 19 17:55:31 puma kernel: usb 4-6: device descriptor read/64, error -110
Jan 19 17:55:31 puma kernel: usb 4-6: reset high-speed USB device number 18 using ehci-pci
Jan 19 17:55:45 puma kernel: usb 4-6: device descriptor read/64, error -110
Jan 19 17:56:00 puma kernel: usb 4-6: device descriptor read/64, error -110
Jan 19 17:56:01 puma kernel: usb 4-6: reset high-speed USB device number 18 using ehci-pci
Jan 19 17:56:11 puma kernel: usb 4-6: device not accepting address 18, error -110
Jan 19 17:56:11 puma kernel: usb 4-6: reset high-speed USB device number 18 using ehci-pci
Jan 19 17:56:16 puma kernel: usb 4-6: device not accepting address 18, error -71
Jan 19 17:56:16 puma kernel: usb 4-6: USB disconnect, device number 18
Jan 19 17:56:17 puma kernel: sd 10:0:0:0: Device offlined - not ready after error recovery
Jan 19 17:56:17 puma kernel: sd 10:0:0:0: [sdb] Unhandled error code
Jan 19 17:56:17 puma kernel: sd 10:0:0:0: [sdb]
Jan 19 17:56:17 puma kernel: Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
Jan 19 17:56:17 puma kernel: sd 10:0:0:0: [sdb] CDB:
Jan 19 17:56:17 puma kernel: Read(10): 28 00 00 06 fa 78 00 00 01 00
Jan 19 17:56:17 puma kernel: end_request: I/O error, dev sdb, sector 457336
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457336) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457337) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457338) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457339) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457340) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457341) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457342) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457343) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457344) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): Directory bread(block 457345) failed
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): FAT read failed (blocknr 286)
Jan 19 17:56:17 puma kernel: FAT-fs (sdb): unable to read inode block for updating (i_pos 7317321)
Jan 19 17:56:17 puma systemd-udevd[27953]: inotify_add_watch(7, /dev/sdc, 10) failed: No such file or directory
Jan 19 17:56:17 puma kernel: usb 4-6: new high-speed USB device number 19 using ehci-pci
Jan 19 17:56:17 puma udisksd[2218]: Cleaning up mount point /run/media/mesb/0123-4567 (device 8:16 no longer exist)
Jan 19 17:56:17 puma udisksd[2218]: Cleaning up mount point /run/media/mesb/SD (device 8:33 no longer exist)
Jan 19 17:56:17 puma kernel: FAT-fs (sdc1): unable to read boot sector to mark fs as dirty
Jan 19 17:56:32 puma kernel: usb 4-6: device descriptor read/64, error -110
Jan 19 17:56:47 puma systemd-udevd[309]: worker [27952] /devices/pci0000:00/0000:00:10.3/usb4/4-6/4-6:1.0/host10/target10:0:0/10:0:0:0/block/sdb timeout; kill it
Jan 19 17:56:47 puma systemd-udevd[309]: seq 2139 '/devices/pci0000:00/0000:00:10.3/usb4/4-6/4-6:1.0/host10/target10:0:0/10:0:0:0/block/sdb' killed
Jan 19 17:56:47 puma kernel: usb 4-6: device descriptor read/64, error -110
Jan 19 17:56:48 puma kernel: usb 4-6: new high-speed USB device number 20 using ehci-pci
Jan 19 17:56:58 puma kernel: usb 4-6: device descriptor read/64, error -110
Jan 19 17:57:13 puma kernel: usb 4-6: device descriptor read/64, error -110
Jan 19 17:57:13 puma kernel: usb 4-6: new high-speed USB device number 21 using ehci-pci
Jan 19 17:57:14 puma kernel: usb 4-6: device not accepting address 21, error -71
Jan 19 17:57:14 puma kernel: usb 4-6: new high-speed USB device number 22 using ehci-pci
Jan 19 17:57:19 puma kernel: usb 4-6: device not accepting address 22, error -75
Jan 19 17:57:19 puma kernel: hub 4-0:1.0: unable to enumerate USB device on port 6
Jan 19 17:57:19 puma systemd-udevd[309]: worker [27952] terminated by signal 9 (Killed)
Jan 19 17:57:19 puma kernel: usb 3-2: new full-speed USB device number 4 using uhci_hcd
Jan 19 17:57:29 puma kernel: usb 3-2: device descriptor read/64, error -110
Jan 19 17:57:45 puma kernel: usb 3-2: device descriptor read/64, error -110
Jan 19 17:57:45 puma kernel: usb 3-2: new full-speed USB device number 5 using uhci_hcd
Jan 19 17:58:00 puma kernel: usb 3-2: device descriptor read/64, error -110
Jan 19 17:58:15 puma kernel: usb 3-2: device descriptor read/64, error -110
Jan 19 17:58:15 puma kernel: usb 3-2: new full-speed USB device number 6 using uhci_hcd
Jan 19 17:58:26 puma kernel: usb 3-2: device not accepting address 6, error -110
Jan 19 17:58:26 puma kernel: usb 3-2: new full-speed USB device number 7 using uhci_hcd
Jan 19 17:58:36 puma kernel: usb 3-2: device not accepting address 7, error -110
Jan 19 17:58:36 puma kernel: hub 3-0:1.0: unable to enumerate USB device on port 2
Comment by Baranko (mesb) - Sunday, 19 January 2014, 16:25 GMT
Looks like i found some dependencies. But as for me it looks very strange,

Using linux box.
If i insert card transcend 4gb 6 class and copy 3gb data into internal memory of player (sd memory mounted too, but not used) all goes fine.
If i insert card transcend 32gb 10 class and copy 3gb data into internal memory of player (sd memory mounted too, but not used) all goes bad, sansa disconnects, hangs etc.

Loading...