Rockbox

Tasklist

FS#12961 - Rockbox Android runs on emulator but not on my phone.

Attached to Project: Rockbox
Opened by Deo Favente (acrox999) - Tuesday, 18 March 2014, 10:25 GMT
Task Type Bugs
Category Operating System/Drivers
Status Unconfirmed
Assigned To No-one
Operating System Android
Severity High
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

For the last couple of weeks, I can't get Rockbox to run anymore on my phone. I use Rasher's build, which used to work fine. I even built one on my own, but it still doesn't work. I tried running it on the emulator and it worked fine. I am not sure what is wrong, reading the logcat gets me nowhere because I don't really understand most of it. I have attached the logcat here. I do not know if I'm the only one having this problem.

I tried various method to get it working again on my phone, I even tried resetting my phone in case if I messed up somewhere. I also noticed this when I was trying out another ROM for my phone, which runs on Gingerbread 2.3.7. I thought it was the ROM's problem, so I changed back to the ROM that I frequently use, which used to had no problems at all running Rockbox. The last working build was on 01 March 2014, after that, nothing works anymore on my phone.

The only possibility that I can think of is that my phone is outdated and the kernel or the ROM is missing something crucial to run the latest Rockbox builds. Other than that, I have no idea. I hope the logcat attached could help you identify this problem. Thank you in advance.

Build version: 915bc09-140318
Last working build (on phone): unknown revision, dated 01 March 2014
Phone: Sony Ericsson Xperia X10
Android: 4.1.2 Jelly Bean (CyanogenMod 10)
Emulator: 4.1.2 (API 16) with same screen dimension.
This task depends upon

Comment by Alex Parker (BigBambi) - Saturday, 22 March 2014, 17:31 GMT
Not the only one, it also has problems here. The first time running it force closed before anything was to be seen on screen, subsequent attempts just gave a black screen. This is a Galaxy S3 i9300 with a 4.4.2 ROM. Version 258e4a
Comment by Deo Favente (acrox999) - Friday, 04 April 2014, 18:49 GMT
Yes, that is exactly how it happened. I'm guessing that it actually runs but is unable to render the screen, for some reasons (that I do not know of).
Comment by Deo Favente (acrox999) - Friday, 04 April 2014, 18:51 GMT
Also not working on Samsung Galaxy Y. Confirmed not working on real phones, but works on emulators.
Comment by Nimos (Nimos) - Sunday, 20 April 2014, 10:37 GMT
What is your devices screen resolution? And what is the screen resolution of the build you are using.
You said you tried making your own build, did your builds, emulators and devices screen resolution match?
Comment by Deo Favente (acrox999) - Sunday, 20 April 2014, 10:56 GMT
It's 480x854. The resolution that I always used from Rasher's build is 480x850, it has always worked fine. The resolution that I chose when making my own build was that one too, the same resolution, 480x854. And yes, as stated on the details section, both emulators and my phone uses the same resolution. Both my build and Rasher's build worked fine on the emulator, but they can't run on my phone. Black screen once loaded, I don't know if it just doesn't load the UI and is actually running, but I doubt that's it because when I go back to Home and re-launch the application, it would hang afterwards.

Why are you asking about the resolutions, by the way? I doubt it has anything to do with the current issue at hand since I tried on two different mobiles phones which have two different resolutions. I don't know what's the cause of it, what is different in the emulator than the real Android smartphones that makes Rockbox not working on it. Perhaps it's because of the recent transition to the new Gcc? I noticed the last commit when it stopped working was that. Something like a toolchain update. I don't really know much, but I'm just assuming this based on the date which Rockbox last worked fine, which is the build that I used from 1st March 2014. Rasher's buildbot did not build anything after that day until the toolchain update, I'm guessing the toolchain is broken at that time.

Again, that is just an assumption but I hope my observation could be of any help to fix this issue.
Comment by Nimos (Nimos) - Sunday, 20 April 2014, 12:04 GMT
I think you meant 480x800, since 480x850 is not available in rasher's build. The reason I am asking about the resolution is that I too had this problem when I used the above build for my galaxy note. It was working till march.
But after change:Id74fa54ba93bbb0ee30373fbe79e92c5ff03201d, (the same time that they updated the tool chain) they have fixed a bug in the LCD and frame buffer code, which now makes a build not work in a device with different resolution that the build itself.
Comment by Deo Favente (acrox999) - Sunday, 20 April 2014, 12:15 GMT
Ah yes, you are right, it is 480x800. It's been a while since I last tried Rockbox. Also, I forgot to mention that there was one time when another build worked on my phone, a build with a different resolution than mine. Just like you said.

Loading...