Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System Sansa Clip+
  • Severity Medium
  • Priority Very Low
  • Reported Version Release 3.13
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by vinz243 - 2014-04-05
Last edited by MikeS - 2017-10-20

FS#12970 - Music stops beyond a certain point on some tracks

Hi,
I am using rockbox 3.13, and on some tracks, the music stops from a certain point and the next track is played.
For instance, this track (https://drive.google.com/file/d/0B8kAEdNtu2xJWTFJM2NIZU1NR28) stops silently at 1:28 and the next track (04) is played (as if the track was 1:28 long). If I come back or even reboot, it will still bug at 1:28. But if I use Sansa’s, the track will be played correctly.
resetting prefs didn’t changed anything.

Closed by  MikeS
2017-10-20 14:46
Reason for closing:  Not a Bug
Additional comments about closing:  

Not a bug per se but FLAC should probably try to push through a minor error. :)

MikeS commented on 2014-04-05 16:34

The file has one or more broken frames. Apparently Rockbox’s FLAC decoder bails out too easily. VLC played it through that time index but there is a small skip there.

Perhaps Rockbox’s decoder should be a bit more tolerant?

MikeS commented on 2014-04-05 16:49

The command-line FLAC decoder returns:

03 It’s a Hard Life.flac: 35% complete03 It’s a Hard Life.flac: * Got error co
de 0:FLACSTREAM_DECODER_ERROR_STATUS_LOST_SYNC
03 It’s a Hard Life.flac: *** Got error code 2:FLAC
STREAM_DECODER_ERROR_STATUS
_FRAME_CRC_MISMATCH 03 It’s a Hard Life.flac: ERROR while decoding data
state = FLAC__STREAM_DECODER_SEARCH_FOR_FRAME_SYNC

The command-line FLAC decoder returns:

How do you access it please ?

MikeS commented on 2014-04-05 20:19

I was just using the command-line decoder from http://xiph.org/flac/ to check it.

Does Rockbox uses the same ?

Loading...

Available keyboard shortcuts

  • Alt + ⇧ Shift + l Login Dialog / Logout
  • Alt + ⇧ Shift + a Add new task
  • Alt + ⇧ Shift + m My searches
  • Alt + ⇧ Shift + t focus taskid search

Tasklist

  • o open selected task
  • j move cursor down
  • k move cursor up

Task Details

  • n Next task
  • p Previous task
  • Alt + ⇧ Shift + e ↵ Enter Edit this task
  • Alt + ⇧ Shift + w watch task
  • Alt + ⇧ Shift + y Close Task

Task Editing

  • Alt + ⇧ Shift + s save task