Rockbox

Tasklist

FS#12975 - Wrong display of some .jpg-files

Attached to Project: Rockbox
Opened by Stefan Waldmann (Rockfan) - Sunday, 20 April 2014, 14:19 GMT
Last edited by Boris Gjenero (dreamlayers) - Wednesday, 06 January 2016, 04:51 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Release 3.13
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi developers,

recently I noticed Rockbox displaying some (not all) .jpg-files too bright and shifted/wrapped around (can't describe it better so excuse my bad English first, please).
This happened with daily build 532b814-140418 but is present in Release 3.13 too. Attached are two examples consisting of .bmp-files (which render OK), the .jpg-files (rendering bad, same size and colors) and some Screendumps illustrating the problem. This Bug (if one) may affect other SanDisk players (Sansa Fuze, e.g.).


Greetings, ...

::
This task depends upon

Closed by  Boris Gjenero (dreamlayers)
Wednesday, 06 January 2016, 04:51 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of  FS#12981  - JPEGs and album art with black backdrops don't display correctly.
Comment by Boris Gjenero (dreamlayers) - Wednesday, 06 January 2016, 04:42 GMT
The problem in both cases is triggered by the entropy data starting with FF 00. Because the FF looks like the start of a marker, process_markers() sets p_jpeg->p_entropy_data to point to the 00 when it should point to FF for correct decoding.

Loading...