Rockbox

Tasklist

FS#12978 - Prefetch or Data abort when setting a theme or playing a song

Attached to Project: Rockbox
Opened by Gianguido Sorà (peppelakappa) - Saturday, 17 May 2014, 15:23 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 18 May 2014, 23:28 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod Classic
Severity Medium
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

While attempting to play a song or set a theme downloaded with the Rockbox Utility on my iPod Classic 6G with dev build Dev build #cb205c8, the player will throw this error.
I'm attaching a photo containing all the useful information to debug it.
This behaviour cannot be reproduced with the build released with EmCORE r859 (Rockbox r31516).
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 18 May 2014, 23:28 GMT
Reason for closing:  Fixed
Comment by MichaelGiacomelli (saratoga) - Sunday, 18 May 2014, 00:24 GMT
Just to be clear, are you running cb205c8 or r31516?
Comment by Gianguido Sorà (peppelakappa) - Sunday, 18 May 2014, 10:36 GMT
I installed the cb205c8 first, then I tried r31516 because of these errors.
If you need any other info just ask and sorry if I made mistakes about the versioning system.
Comment by Jonathan Gordon (jdgordon) - Sunday, 18 May 2014, 10:49 GMT
should be fixed in 62d357b
Comment by Gianguido Sorà (peppelakappa) - Sunday, 18 May 2014, 11:19 GMT
are these changes already pushed to git?
if so I'll build and report here
Comment by Gianguido Sorà (peppelakappa) - Sunday, 18 May 2014, 15:00 GMT
With the latest development build I cannot reproduce this bug anymore.
Thanks a lot for your help.

Loading...