Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System Sansa Clip Zip
  • Severity Medium
  • Priority Very Low
  • Reported Version Release 3.13
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by dryphi - 2014-07-08
Last edited by saratoga - 2014-07-08

FS#12989 - Autodetect crashes installer

New to Rockbox.. Recent owner of a Sansa Clip Zip with 1.01.21 firmware on a Windows 8.1 PC.

Whenever I start the Rockbox Utility, upon being presented with the Configuration screen, when I press “Autodetect” I get the ‘ol “Rockbox Utility has stopped working… Windows is searching for a solution to this problem” popup.
I believe this may be related to the fact that Windows 8 doesn’t give the Clip Zip a drive letter; it appears as simply “Sansa Clip Zip 4GB” in My Computer. However I can access it and copy/paste to/from all folders therein.

Do I need to strongarm Windows into assigning a drive letter to the Clip Zip?

Thanks!

Closed by  saratoga
2014-07-08 02:45
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in git, will be distributed with next rbutil release.

Nevermind actually.. Problem solved. I put the device into MSC mode instead of Autodetect and it worked.
Still, I imagine this is a common error, especially for newbies to Rockbox. Instead of crashing the installer it would be helpful if a popup prompted the user to manually put the MP3 player into MSC mode.
Thank you.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing