FS#12990 - PANIC in usb_storage_init_connection on iPod Classic

Attached to Project: Rockbox
Opened by Ken H (chosenken) - Friday, 01 August 2014, 03:51 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 28 August 2016, 20:03 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod Classic
Severity High
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


I occasionally receive the following PANIC error on my iPod Classic (80 GB, S/N ending in YMV) when I attempt to access the device over USB:

usb_storage_init_connection(): OOM
pc:08058E30 sp:080C9D48
A: 08056FD8
A: 080575C0
A: 080489EC
bt end

This happens when I attempt to change directories or copy new files over.

The device has emCORE 0.2.3 r859 and is running Rockbox build 78f4f7b-140730. My desktop is running Windows 8.1 x64.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 28 August 2016, 20:03 GMT
Reason for closing:  Out of Date
Additional comments about closing:  New USB stack was committed, closing bug reports on the old one.
Comment by Thomas Martitz (kugel.) - Friday, 01 August 2014, 08:04 GMT
Does this happen as soon as you connect or only when you start to transfer files?
Comment by Ken H (chosenken) - Friday, 01 August 2014, 14:39 GMT
It happens at different points. The first time I opened the device in windows explorer and it listed the folders. I double clicked on the .rockbox folder and the panic happened. The second time I had created a new folder in the root called Music. When I tried to copy a folder into the Music folder, the panic happened. The panic happening when I navigate the folders or copy over files.

Also after I connect the device to my system, it will take time for the device to be mounted.
Comment by shawn looker (slooker) - Monday, 24 November 2014, 19:18 GMT
I have the same problem. It will show the usb connected symbol on my ipod, but it won't show up on my computer. It will flash back and forth between usb and the standard rockbox menu for a second. After a few more seconds, it will be recognized in my computer for ~1 second before I get the above error.
Comment by andreas (gsw33d) - Wednesday, 01 July 2015, 03:11 GMT
is det a fix to this i add 10 song to test my pod but after i gonig to put more song to my pod no pod show op at windows exploerer so i must del my rockbox and run it angen fro, det boot meny from the pod