Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#12992 : Can't create playlist with all tracks on device (regression)

Rockbox

Tasklist

FS#12992 - Can't create playlist with all tracks on device (regression)

Attached to Project: Rockbox
Opened by Joseph Shraibman (tupari) - Monday, 25 August 2014, 16:07 GMT
Last edited by Willliam W (Bilgus) - Saturday, 17 August 2019, 11:37 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System All players
Severity Medium
Priority Normal
Reported Version Release 3.13
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I go into the Playlists menu and select Create Playlist instead of creating a playlist file with all tracks on the device like it used to it creates and empty Playlists.m3u8 file. The problem seems to be in tree.c:

if (tc.currdir[1])
snprintf(filename, sizeof filename, "%s.m3u8", tc.currdir);
else
snprintf(filename, sizeof filename, "%s/all.m3u8",
catalog_get_directory());

I'm guessing that it used to be that the Create Playlist would be accessed from the main menu and tc.currdir wasn't set to anything, but now the Playlists menu item sets c.currdir to the Playlists directory because that is where playlists are stored now. So now instead of putting all tracks into all.m3u8 it creates an empty file (since there aren't any audio files under the Playlists directory).
This task depends upon

Closed by  Willliam W (Bilgus)
Saturday, 17 August 2019, 11:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in DEV version fd19a2c

Loading...