Rockbox

Tasklist

FS#13000 - Audio drop-out with hi-res file playback

Attached to Project: Rockbox
Opened by Aaron Tate (darthtater) - Friday, 19 September 2014, 20:47 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 19 October 2014, 20:02 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version Release 3.13
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a couple of hi-res files (24/44) that seems to have audio volume drop-outs at certain points, as if it is an over-reacting dynamic clip prevention. If I try the same file in Foobar 2000, I do not get the sound drop-outs. Dithering is turned on, ReplayGain is on "album", and I tried it both with and without clipping prevention, but both times I got the drop-outs.

The file is too large to attach here, but I can provide it via other means. They are tracks from Steven Wilson - The Raven That Refused to Sing. I resampled and dithered the official 24/96 release to 24/44 using iZotope RX 3 Advanced. I can provide both resampler and dither settings if desired, or I can just provide the effected tracks (title track, "The Watchmaker", both near the end), or the files themselves.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 19 October 2014, 20:02 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No test file or response, but probably the issue is just too slow of a CPU for (unspecified) format and DSP effects selected.
Comment by MichaelGiacomelli (saratoga) - Saturday, 20 September 2014, 22:54 GMT
I'd suggest linking a part of the file that has the problem, or else making a shorter sample that has it. Otherwise its basically impossible to tell you anything, I don't even know what format you're using. Could be anything from your CPU being too slow to decode the file to a bug in one of the decoders.

Loading...