Rockbox

Tasklist

FS#13013 - Particular file kills software upon playback

Attached to Project: Rockbox
Opened by David McMackins II (2mac) - Friday, 14 November 2014, 12:10 GMT
Last edited by MichaelGiacomelli (saratoga) - Friday, 14 November 2014, 16:00 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa Clip Zip
Severity High
Priority Normal
Reported Version Release 3.13
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

A particular audio track will cause the entire system to freeze and not respond to any input after it reaches 1 second of playback.

The audio file is fine to all other media players, and I even tried re-enconding it and replacing it in case of a corruption to no avail.

I can't attach the file in here, but you can download it at http://mcmackins.org/dl/music/cof.ogg

The only way I can regain control of my device is to let the battery die. None of the buttons offer a response otherwise; it halts the entire system.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Friday, 14 November 2014, 16:00 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  File decodes normally in the sim and on device.
2014-11-15: A request to re-open the task has been made. Reason for request: Power button does not power-off the device in the frozen state. No button input is recognized.
Comment by MichaelGiacomelli (saratoga) - Friday, 14 November 2014, 15:59 GMT
That file plays fine on the clip zip, so I doubt its a problem specific to that file. I'd check that your file system is ok, update your build, etc. If you need more help, ask in the forums.

By the way, if your player crashes, you can reboot it by holding the power button.

Loading...