FS#13014 - (19f4e39) USB connection does not work on Sansa Clip+

Attached to Project: Rockbox
Opened by Bykov Vladislav (envolyse) - Wednesday, 19 November 2014, 16:49 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 28 August 2016, 20:05 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System Sansa Clip+
Severity High
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


USB charging works fine. It just USB connection that does not work.
Currently installed version is 19f4e39. Here is dmesg on FreeBSD 10.0-RELEASE-p7:

uhub_reattach_port: giving up port reset - device vanished
usbd_req_re_enumerate: addr=11, set address failed! (USB_ERR_IOERROR, ignored)
usbd_setup_device_desc: getting device descriptor at addr 11 failed, USB_ERR_IOERROR
usbd_req_re_enumerate: addr=11, set address failed! (USB_ERR_IOERROR, ignored)
usbd_setup_device_desc: getting device descriptor at addr 11 failed, USB_ERR_IOERROR
usb_alloc_device: Failure selecting configuration index 0:USB_ERR_IOERROR, port 2, addr 11 (ignored)
ugen0.2: <> at usbus0
ugen0.2: <> at usbus0 (disconnected)

However, it works just okay in stable 3.13 realease.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 28 August 2016, 20:05 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Closing bug reports on the old USB stack now that the new one is stable and committed.
Comment by Charles King (charleski) - Saturday, 27 December 2014, 12:51 GMT
I can confirm this bug on Windows 7.

Here is the behaviour on the 3.13 stable release:
1) ClipZip screen must be on when plugging in USB, otherwise device is not connected at all.
2) After plugging in the device 'My Computer' spends a couple of minutes refreshing (green bar moving left to right in address bar) before the disks are finally mounted. But from then on it works fine and there are no problems transferring data or unmounting the disks.

I tried two dev builds to see if they provided improved repsonse, 30 Nov (8618f2c) and 22 Dec (9a5f7ce). Both completely failed to connect to the computer. I would typically hear a <device connect> sound followed at once by a <device disconnect> sound. Dev manager showed a non-functioned WPD File System device with a Code 10 error (this device cannot start).
Moving the connection to a different USB port or trying a USB port directly sited on the MB rather than a hub produced exactly the same behaviour. Deleting the device in dev manager and reinstalling produced exactly the same behaviour.

On booting into the stock firmware the USB connection works flawlessly, with both internal storage and the uSD card immediately showing up as disks.

I reverted back to 3.13 stable and the connection now works again, in the same manner as described above.

Comment by josh platt (plonkety) - Friday, 16 January 2015, 11:46 GMT
I had the same problem, but on the sansa clip zip with 3.13 stable release. Thankfully the connection worked when i opened up the ##port## folder on the files section and then connected it to my computer via usb. Maybe it will work for you also if you try this?
Comment by Wenchang (ghanz84) - Sunday, 22 February 2015, 14:15 GMT
I have the same issue too on 3.13 release.
Josh's workaround works well for me.
Going to try a nightly build to see if it fixes it.