FS#13015 - Sansa Fuze v2 not working--Rockbox killed it

Attached to Project: Rockbox
Opened by Anna Haugen (annahaugen) - Wednesday, 03 December 2014, 03:15 GMT
Last edited by MichaelGiacomelli (saratoga) - Wednesday, 03 December 2014, 04:41 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System All players
Severity Critical
Priority Normal
Reported Version Release 3.13
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have a Sansa Fuze (v2) that I've had for years. Recently it stopped loading playlists, and a search of the Sansa Fuze forums suggested installing Rockbox instead, so I did. (And you really, really don't want non-techies doing this, do you? There is so much confusing stuff in the documentation and how-to-install stuff that I almost gave up multiple times. Now I wish that I had.)

I used your installer to install Rockbox (using the fuze02.03.33 file, which I'm pretty sure was the correct one).

It installed just fine initially. When it was done, I ejected it from my Windows 7 laptop and Rockbox initialized. I poked around for a little bit, looking at how things were organized, and decided to see how loading music onto it worked. So I plugged it back into my computer. Nothing came up--my computer can't see the player now, nor the microSD card. So I unplugged it from my computer. And now the screen on the player shows this message:

SWI at 300C0350
pc:300C0350 sp:300A086C
bt end

It does not respond to anything. It will not turn off. I have tried pushing every button on it, and nothing changes anything. I have tried connecting it to the computer again.

This is the error message my computer now gives me:
One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it.

Basically, your software has turned a player that worked but had one minor annoyance into an expensive piece of junk. Please tell me how to fix it. If this can't be fixed, you need to replace it.``
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Wednesday, 03 December 2014, 04:41 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Tech support should go in the support forums, not the bug tracker.

BTW, the next time your player crashes you can reboot it by holding the power button.
Comment by Anna Haugen (annahaugen) - Wednesday, 03 December 2014, 04:31 GMT
Okay, I was too quick off the gun. After about an hour my Sansa Fuze allowed me to restart it and seems to be working. But that was pretty scary. Particularly because there was no way to find out any information about what might be wrong or that it might fix itself.