Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#13018 : ALAC playback on iPod CLassic 7G 160GB

Rockbox

Tasklist

FS#13018 - ALAC playback on iPod CLassic 7G 160GB

Attached to Project: Rockbox
Opened by Luk Pe (lukpe) - Thursday, 18 December 2014, 10:58 GMT
Task Type Bugs
Category Codecs
Status Unconfirmed
Assigned To No-one
Operating System iPod Classic
Severity Medium
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

There is an ALAC playback problem in daily builds (since 2014-11). The playback somethimes works for one song but then crashes and shows ALAC file details as "? kbit/s", "0 MHz", "0 MB" and nothing happens when I press the Play button. After reboot the problem occurs again. It makes the ALAC playback impossible.

Now I'm using revision 9cb9f76M-140326 with patches from aroldan:

https://www.dropbox.com/sh/b5xbw6cp4ikfxwn/MjELjmDNJ_

With this build there are no ALAC playback problems.
This task depends upon

Comment by MichaelGiacomelli (saratoga) - Thursday, 18 December 2014, 17:30 GMT
Alac hasn't changed in a very long time. Do you have trouble playing other files?
Comment by Luk Pe (lukpe) - Thursday, 18 December 2014, 18:52 GMT
No, the problem concerns only ALAC files. At first I thought that the files got corrupted during transfer, but on the older firmware I can play any album without errors.
Comment by Ben Olson (benbenolson) - Thursday, 24 October 2019, 05:06 GMT
Luk Pe,

Any updates on this? I'm trying to resurrect some of these old Rockbox bug reports. Have you tried the latest version, unpatched?

Thanks,
Ben
Comment by Matt (iCr) - Friday, 10 January 2020, 09:55 GMT
Ben, i`m installed current stable version of 3.15 RB at 7G Classic, and it freeze every time when i trying to play ALAC files from my iTunes library. it hangs when i trying to play some of files at Searching... xx found (PLAY/PAUSE to abort)

Loading...