FS#13031 - Sansa e200 lamp plugin: wheel light does not turn off

Attached to Project: Rockbox
Opened by David Buck (buckyballreaction) - Sunday, 22 February 2015, 05:39 GMT
Last edited by Frank Gevaerts (fg) - Sunday, 22 February 2015, 11:31 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Release 3.13
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



I recently found our two old old Sansa e280 players (one is v1, the other v2) and updated it to Rockbox 3.13. I attempted to use the lamp plugin (with red light) of one for reading a book late at night; however, the scroll wheel light never shut off and is blindingly bright for reading. The older version of rockbox didn't do this (I can't remember what version, but it was at least 2+ years older).

This happens with both versions of the e280 and I even attempted to run the latest SVN of rockbox (from about a week ago) to no effect. I usually have the system set to always have the wheel light off, and fiddling with these settings does not affect it within the lamp plugin - it's always on, continuously.
This task depends upon

Closed by  Frank Gevaerts (fg)
Sunday, 22 February 2015, 11:31 GMT
Reason for closing:  Fixed
Comment by Frank Gevaerts (fg) - Sunday, 22 February 2015, 11:31 GMT
This behaviour has been there for a *long* time, and seems to be by design. The commit that always switches the buttonlight on is from 8 may 2008, while the entire lamp plugin was added on 23 april 2008, so your previous build must have been from within those two weeks...

Now I agree that this can be annoying, so I've now added toggling the button light using the select button (revision 272b558). If you update to the current development build, you should get this.