Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Playlists
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by taw - 2015-03-21
Last edited by speachy - 2024-04-01

FS#13040 - Playlist becomes one item shorter when shuffled

I noticed that the playlist seems to become one item shorter when I shuffle it, using the latest Git master branch (commit 70d57080) on a Sansa Clip+.

Steps to reproduce:
1. Clear the playlist by pressing Stop (power button)
2. Add a small number of tracks to the playlist
3. Shuffle the playlist (playlist view, menu, Shuffle)
4. Observe that playlist is one item shorter than before

I tracked the reason for this down, and attach a patch. This isn’t a “proper” fix, and is a bit hacky, but it does illustrate what causes the problem.

Closed by  speachy
2024-04-01 00:20
Reason for closing:  Out of Date

this problem yes

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing