Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#13047 : Fuze v1 database is extremely slow

Rockbox

Tasklist

FS#13047 - Fuze v1 database is extremely slow

Attached to Project: Rockbox
Opened by John (plsng) - Monday, 25 May 2015, 19:57 GMT
Last edited by Solomon Peachy (pizza) - Monday, 24 December 2018, 02:41 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System Sansa AMSv1
Severity High
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Build 47d0537, Fuze v1, also happens on Clip+ as seen here: http://www.rockbox.org/tracker/task/13026

The database on the Fuze v1 is very slow in loading: when you select an artist/album/..., it takes about a second or two for the list of albums/tracks/... to show up. On the latest stable release this is instant. This problem has likely been around since http://git.rockbox.org/?p=rockbox.git;a=commit;h=7d1a47c
This task depends upon

Closed by  Solomon Peachy (pizza)
Monday, 24 December 2018, 02:41 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Works now, apparently
2019-01-10: A request to re-open the task has been made. Reason for request: Unfortunately it looks like the issue either returned in a more recent build or the time it started to work normally again was a fluke and it wasn't fixed. The database on the Fuze v1 is still or again slow as molasses. The issue is definitely fixed on the Clip (Zip), though.
Comment by John (plsng) - Thursday, 28 December 2017, 14:51 GMT
Confirmed fixed in daily build as of a recent commit. Can be closed.

Loading...