FS#13075 - [Clip Zip] Player crashes when opening certain files

Attached to Project: Rockbox
Opened by Daniil (GeneralFailer) - Saturday, 04 June 2016, 19:02 GMT
Task Type Bugs
Category Operating System/Drivers
Status Unconfirmed
Assigned To No-one
Operating System Sansa Clip Zip
Severity Critical
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


Version: recent daily (I'm only sure it's newer than 86df983).
The player drops into "data abort" message if I try to open certain M4A and Opus files including the one in the attachment.

I'm now stuck in the boot loop because of the player trying to open it again every time.
This task depends upon

Comment by Daniil (GeneralFailer) - Saturday, 04 June 2016, 19:28 GMT
Is the file not attached?
Comment by MichaelGiacomelli (saratoga) - Saturday, 04 June 2016, 22:29 GMT
That AAC file won't play because the MP4 container isn't "web optimized". Repacking it like a normal audio file fixes playback.

I'm surprised it crashes the player though instead of just rejecting the file. I'll try and find time to figure out why.
Comment by Daniil (GeneralFailer) - Sunday, 05 June 2016, 08:30 GMT
Is there a button combination or something to stop the boot loop?
Comment by Daniil (GeneralFailer) - Sunday, 05 June 2016, 11:52 GMT
OK, I solved the loop by booting to the stock firmware.
Did you mean because it is web-optimized? Why doesn't Rockbox support this type of files?
Comment by Daniil (GeneralFailer) - Sunday, 05 June 2016, 12:20 GMT
Also what should I do to make them compatible? I tried using FFmpeg with "-codec:a copy" option on them, but they crash Rockbox all the same.
Comment by Daniil (GeneralFailer) - Sunday, 05 June 2016, 17:43 GMT
I read the FAQ answer on AAC, so you can ignore that question, I guess.
Comment by MichaelGiacomelli (saratoga) - Sunday, 05 June 2016, 18:08 GMT
There is an FFMPEG switch to create MP4 files designed for audio playback/portable devices. You need to hit that if you want to play them on less powerful portable devices. Otherwise you get the video type ones which are tricky to decode on devices without a lot of RAM.

Really though FFMPEG's internal AAC encoder isn't very good. Unless you need ffmpeg compatibility, I'd just use iTunes/FDK/Nero. That way you'll get a normal MP4 formatted file and better quality.
Comment by Daniil (GeneralFailer) - Sunday, 05 June 2016, 18:10 GMT
I'm using Linux.
Comment by MichaelGiacomelli (saratoga) - Sunday, 05 June 2016, 19:37 GMT
You want to be using FDK then most likely. You can also use it through ffmpeg if you want, but its probably easier not too, and if you do make sure you set the MP4 container settings correctly for portable use.

I also updated the AAC FAQ entry to cover this.
Comment by Daniil (GeneralFailer) - Sunday, 05 June 2016, 20:09 GMT
I'm having a hard time comprehending your statement about this being just a container problem in your original comment. There doesn't seem to be anything useful here IMO.
Comment by MichaelGiacomelli (saratoga) - Monday, 06 June 2016, 16:55 GMT
Check Google, there are guides explaining how to set ffmpeg parameters. Or just use something simplier.