Rockbox

Tasklist

FS#13081 - Sansa Clip+ not able to opus files

Attached to Project: Rockbox
Opened by Harry Hirsch (capreolus) - Monday, 22 August 2016, 20:55 GMT
Last edited by MichaelGiacomelli (saratoga) - Thursday, 25 August 2016, 18:43 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System Sansa Clip+
Severity Medium
Priority Normal
Reported Version Release 3.13
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I recently started to encoded flac files to opus I used "opusenc --bitrate 128". Clip+ can't play these files. Either the display looks normal, but is stuck before playing has actually started. I then have the only choice to shut down the player by very long pressing the power button. In other cases (even using the same file) a crash screen shows up. These vary, e.g. "Data abort at 3000742x / FSR 0x8 / (domain 0, fault 8) / address 0x6F377473 / pc:30007420 sp: 30803Bx / bt end" or "Undefined instruction / pc: 30000BF7C sp: 3000008x / bt end" or "Data abort at 3004516x / FSR 0x0 / (domain 0, 0xBFFFF87B / pc: 30045168 sp: 30803Bx / bt end". There seem to be more charactersin the lines where I have put a 'x'. I can not scroll, becaus as soon as I press a button, the player shuts down.
opusenc -V reports: "opusenc opus-tools 0.1.9 (using libopus 1.1.2)"
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Thursday, 25 August 2016, 18:43 GMT
Reason for closing:  Fixed
Comment by MichaelGiacomelli (saratoga) - Tuesday, 23 August 2016, 01:31 GMT
There have been massive improvements to Opus since 3.13. Update your build and see if the problem is fixed.
Comment by Harry Hirsch (capreolus) - Wednesday, 24 August 2016, 21:05 GMT
With build 108a0f3 installed everything works fine so far, especially in respect to opus files. Thank you!

Loading...