FS#13083 - Ipod Classic playback jumping

Attached to Project: Rockbox
Opened by Emanuel (Termo) - Friday, 16 September 2016, 19:49 GMT
Task Type Bugs
Category Music playback
Status Unconfirmed
Assigned To No-one
Operating System iPod Classic
Severity Critical
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


I've been using the development version of Rockbox in my ipod classic 6th generation for about two years I think, but from some time, like a month or two, I'm experiencing playback issues as the track I'm listening suddenly skip forward or backward, or even jump for a few seconds on another mp3 file inside the ipod I was just listening before. I don't think is a ipod issue because I can listen the file inside the ipod with my computer player without problems.

There some way I can check older development revisions for the classic? It appears that it doesn't show in the dev build link on the site because is not fully supported. Thanks
This task depends upon

Comment by MichaelGiacomelli (saratoga) - Saturday, 17 September 2016, 17:35 GMT
The download server has the last few days worth of builds, but for more than a month old you will need to compile yourself.

What build are you running?
Comment by Emanuel (Termo) - Saturday, 17 September 2016, 23:51 GMT
Thanks, don't know how to do it but I can learn :D Actually I'm using the last one. I've not found why, but just some tracks appears to jump. Searching for a pattern :)
Comment by MichaelGiacomelli (saratoga) - Sunday, 18 September 2016, 02:09 GMT
Which build is the last one?
Comment by Emanuel (Termo) - Sunday, 18 September 2016, 10:11 GMT
1f8ea9f, up to date :)
Comment by Emanuel (Termo) - Monday, 19 September 2016, 15:52 GMT
I think I've found the problem, the internal hard disk is probably faulty or has accumulated many errors during time, but chkdsk doesn't work (give me an error). Now after trying to backup data, I've messed a bit with the internal structure of directories and files, deleting something, trying to copy files that appeared corrupted, and now I can't see the ipod hard disk anymore on the pc, while inside Rockbox music playback is as fine as it were before. There is any solution? I've tried with a fall back rockbox image, but doesn't work. I need to try a backup before formatting, and even formatting from emcore will assure to resolve the problem?