Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 FS#13096 : Playlist Catalogue > Add to New Playlist misplaces caret

Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Battery/Charging
  • Assigned To No-one
  • Operating System Creative ZEN
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.13
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by chrisjj - 2017-01-08
Last edited by Bilgus - 2019-08-17

FS#13096 - Playlist Catalogue > Add to New Playlist misplaces caret

I found this on Creative ZEN, but I’d guess it is present on all players.

Playlist Catalogue > Add to New Playlist places the caret /after/ the extension http://i.imgur.com/C8zcSto.png , the default result of the user entering character is a filename having a different extension http://i.imgur.com/D5aEiA8.png and hence unrecognised by RB.

User workaround: Click Up, Left, Left, Left, Left, Down

Proposed fix: place the caret at the end of the basename http://i.imgur.com/ahtOfnm.png

Closed by  Bilgus
2019-08-17 11:45
Reason for closing:  Not a Bug
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

kbd_input doesn't have functionality to move the caret anywhere but the end of the string

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557
Proposed fix: place the caret at the end of the basename http://i.imgur.com/ahtOfnm.png

Even better would be to hide the extension.

This would protect it against less direct inadvertent user edits too.

And it would also prevent any deliberate user edit to the extension, but I can’t see why anyone would want to do that, given any change makes the playlist inaccessible to RB. If there was a good reason, this use could be allowed by making the input control’s inclusion of the extension conditional on Files > Settings > Show Filename Extensions.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing