Rockbox

Tasklist

FS#13099 - Crash after USB plug

Attached to Project: Rockbox
Opened by Daniil (GeneralFailer) - Monday, 23 January 2017, 15:53 GMT
Last edited by MichaelGiacomelli (saratoga) - Wednesday, 08 February 2017, 23:27 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System Sansa Clip Zip
Severity Critical
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The screen briefly flashes an Incorrect CPU Mode message and then displays a Data Abort one. This even affects plugging to a power socket.

Version: latest nightly (28bf763)
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Wednesday, 08 February 2017, 23:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 783c775.
Comment by Wolfgang Dilg (rasferret) - Monday, 23 January 2017, 20:33 GMT
I can confirm that the firmware is crashing with the newest build when plugging in a charger.
Comment by amaury pouly (pamaury) - Monday, 23 January 2017, 20:45 GMT
The problem is known and there is a patch pending (http://gerrit.rockbox.org/r/#/c/1522/).
Comment by Daniil (GeneralFailer) - Monday, 23 January 2017, 21:09 GMT
Any ideas on how to update it then? Stock firmware gets stuck on refreshing media; I assume because of some files in internal memory.
Comment by amaury pouly (pamaury) - Monday, 23 January 2017, 21:31 GMT
There isn't much to do right now, just wait until the fix is committed.
Comment by Daniil (GeneralFailer) - Monday, 23 January 2017, 21:35 GMT
I'm asking in advance.
Comment by Daniil (GeneralFailer) - Wednesday, 25 January 2017, 22:07 GMT
So, any ideas, now that it's merged?
Comment by MichaelGiacomelli (saratoga) - Wednesday, 08 February 2017, 23:27 GMT
Update your build using the bootloader USB mode if you can't use the OF. See forums if you need further help.

Loading...