Rockbox

Tasklist

FS#13116 - Playback freezes with some files

Attached to Project: Rockbox
Opened by Sven Greiner (SammysHP) - Wednesday, 03 May 2017, 10:49 GMT
Last edited by MichaelGiacomelli (saratoga) - Wednesday, 03 May 2017, 20:29 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa Clip+
Severity Critical
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I just updated to 3.14 and while some files play fine, with a specific file the following happens after 1-3 seconds of playback:

- Playback stops
- Buttons do not respond
- Title is still scrolling

I am able to reproduce the issue every time.

PS: New release 3.14 is missing in Flyspray.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Wednesday, 03 May 2017, 20:29 GMT
Reason for closing:  Works For Me
Additional comments about closing:  Probably some SD card weirdness.
2017-05-06: A request to re-open the task has been made. Reason for request: Regression from 3.13 to 3.14. Related to SD card access during playback.
Comment by Sven Greiner (SammysHP) - Wednesday, 03 May 2017, 19:28 GMT
Just a quick follow-up: First I checked if I can read the file via a cardreader with my PC. That worked. So saratoga tried the file on his Clip+ and it worked without problems. So I tested a little bit…

1) Reset configuration to default. No change.

2) Copy file from SD to internal storage with Rockbox. The copied file could be played. Conclusion: Rockbox was able to read the file and play the copy.

3) Delete file from SD via PC and copy it back to the SD. This file could be played by Rockbox!

I don't understand why Rockbox was unable to play the "corrupted" file, but could copy it to the internal storage without problems. I couldn't find anything suspicious on the SD card. The file was not fragmented and I was able to read and write the corresponding sectors. As multiple files in the same area were affected it might be a problem with the SD card, but it's weird that my PC and Rockbox were able to read it during the copy operation.

Loading...