Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#13119 : Sansa Clip+ doesn't restore Timestrech settings after power cycle

Rockbox

Tasklist

FS#13119 - Sansa Clip+ doesn't restore Timestrech settings after power cycle

Attached to Project: Rockbox
Opened by Brian Hall (brihall) - Sunday, 25 June 2017, 12:56 GMT
Last edited by Willliam W (Bilgus) - Sunday, 04 August 2019, 20:16 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System Sansa Clip+
Severity Low
Priority Normal
Reported Version Release 3.14
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After creating a bookmark and a power cycle, when resuming playback Clip+ does not restore the Timestrech setting, like Rockbox does on my Sansa e200v1. Timestrech setting does persist on Clip+ when stopping/resuming playback during the same power-on.

I like to set the Speed to 225% for listening to podcasts. Clip+ should restore the Timestrech settings from the previous boot, so don't have to manually re-set the Speed on every power-on.

Ideally, Timestrech setting should be saved with the bookmark, or at least be saved per-directory, on all builds, IMHO.

Thanks.
This task depends upon

Closed by  Willliam W (Bilgus)
Sunday, 04 August 2019, 20:16 GMT
Reason for closing:  Not a Bug
Comment by Johannes Rauh (johnbtracker) - Sunday, 02 July 2017, 10:15 GMT
Timestretch IS saved with the bookmark!
After the power-on, if you select 'Recent Bookmarks' instead of 'Resume Playback' the stored Timestretch is active.

I confirm (on my clip+) that is not active, when resuming playback.

I don't consider this as a problem.
Comment by Brian Hall (brihall) - Sunday, 02 July 2017, 20:41 GMT
Confirmed, thanks! "Recent Bookmarks" restores the previous timestrech setting even after a power cycle on my Clip+. I was just expecting the timestretch setting to be restored on power cycle + Resume Playback also. That would be useful in Car Adapter mode, I think.

Doing it via "Recent Bookmarks" is actually the same way I'm using the feature on my e200.


For anyone searching the comments later, this feature is working as documented in section 4.3.3 of the manual.

"The value of the rate, pitch and speed is not persistent, i.e. after the player is turned on it will always be set to 100%. However, the rate, pitch and speed information will be stored in any bookmarks you may create (see section 8.7) and will be restored upon playing back those bookmarks."

https://download.rockbox.org/daily/manual/rockbox-sansaclipplus/rockbox-buildch4.html#x6-620004.3.3

Loading...