Rockbox

Tasklist

FS#13125 - Playback drops out while screen is active

Attached to Project: Rockbox
Opened by Jack Smith (dvbugz) - Sunday, 23 July 2017, 04:16 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 23 July 2017, 19:12 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Critical
Priority Normal
Reported Version Release 3.14
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Audio playback seems to have occasional but regular "breaks" when the screen is active. I.e. it will play for about 10 seconds, pause for a couple, resume playing, pause, rinse and repeat until the screen blanks. After the screen goes blank playback continues as normal. It doesn't seem to matter if the backlight is on or not, just if there is anything showing on the screen. Experiencing the problem on both a stock and Compactflash modded 5.5 80GB (model A1136) running version 3.14.

So far I only have only been using MP2 and MP3 files with Rockbox so I don't know if it's specifically a MP3 decoder issue or something else. Anyways, here it is.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 23 July 2017, 19:12 GMT
Reason for closing:  Accepted
Comment by Jack Smith (dvbugz) - Sunday, 23 July 2017, 05:03 GMT
Okay, I fixed it. It appears to be related to the peak meter display because the theme I used had one (Detailstext). Commenting out the "%pm" line in the wps file and reloading it gets rid of the meter and seemed to fix it. I suppose with meter on it's trying to do too much at one time with the limited CPU these devices have.

Loading...