Rockbox

Tasklist

FS#13128 - rockbox doesn't show correct song/artist name when playing file with CUE sheet

Attached to Project: Rockbox
Opened by pokazene maslo (pokazene_maslo) - Friday, 08 September 2017, 09:11 GMT
Last edited by Michael Sevakis (MikeS) - Saturday, 21 October 2017, 20:02 GMT
Task Type Bugs
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Medium
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I tried latest beta build for my iRiver iHP120 (iriver H120/140 c6d5cd7) and when I play a long music file with CUE sheet, Rockbox will not update artist/track name on the display correctly.

steps to reproduce:
1. you need some long mp3 file with cue sheet (you can grab a CD with EAC to a long mp3 with CUE sheet)
2. enable cue sheet support in Rockbox menu
3. start playing back the file
4. Artist/track name will be correctly shown for the first track, but if you wait until next track the problem will emerge: track/artist name on display will not update.

I can help with testing and I'm offering some money to the good person that will fix this.

Thanks!
This task depends upon

Closed by  Michael Sevakis (MikeS)
Saturday, 21 October 2017, 20:02 GMT
Reason for closing:  Invalid
Additional comments about closing:  Reporter requested task be closed. Was using outdated themes.
Comment by MichaelGiacomelli (saratoga) - Saturday, 09 September 2017, 21:03 GMT
If you post a link to a file with this problem I can try and take a look at it.
Comment by pokazene maslo (pokazene_maslo) - Sunday, 10 September 2017, 11:16 GMT
you can download for example this radio show:
http://cuenation.com/?page=tracklist&folder=asot&filename=Armin+van+Buuren+-+A+State+Of+Trance+830+%28256+Kbps%29+baby967.cue
there is one link to download CUE sheet (simple text file with .cue extension) and two links to file hosters where is the actual MP3 recording of the radio show. Just start playing it and wait for 50 seconds, at 50th second the second track begins "W&W X Vini Vici - Chakra [TUNE OF THE WEEK]"

Comment by pokazene maslo (pokazene_maslo) - Tuesday, 12 September 2017, 14:31 GMT
The same problem occurs when resuming playback.

steps to reproduce:
1. open MP3 file with cue sheet
2. seek couple tracks forward
3. stop playback
4. start playback
Rockbox will resume the playback where it was stopped but will show name of the first track in CUE sheet instead of the currently playing track.
Comment by Michael Sevakis (MikeS) - Wednesday, 13 September 2017, 01:40 GMT
I've tried Gigabeat S and H120 according to your recipe and cannot duplicate this. I can start the file directly or pick a track in the cuesheet browser and everything displays fine and updates correctly. Are you using a non-default theme?
Comment by pokazene maslo (pokazene_maslo) - Wednesday, 13 September 2017, 10:38 GMT
I use WPS theme "boxes"
Comment by pokazene maslo (pokazene_maslo) - Friday, 29 September 2017, 14:14 GMT
Hi. I can confirm that this bug is still present in latest dev build "13364c552". Could anyone here try WPS theme "boxes"?
Comment by Michael Sevakis (MikeS) - Friday, 20 October 2017, 14:09 GMT
I just tried it on H120 with the most recent Boxes theme and 1eab18c and it switches to "W&W X Vini Vici, Chakra [TUNE OF THE WEEK]" just fine.

Edit: I mean, it takes a few seconds to show it because it takes a moment to switch from the track info to the cue sheet metadata.
Comment by pokazene maslo (pokazene_maslo) - Friday, 20 October 2017, 18:11 GMT
I really have no idea why nobody else is experiencing this bug. I just tried latest dev build 1eab18c9e. I'm attaching my cfg file. Maybe it will help to reproduce this bug.
Comment by pokazene maslo (pokazene_maslo) - Saturday, 21 October 2017, 13:36 GMT
Hi all. I found out that i used old themes. After downloading new themes everything is all right. I'm sorry.

Loading...