Rockbox

  • Status Closed
  • Percent Complete
    0%
  • Task Type Bugs
  • Category Music playback
  • Assigned To
    Bilgus
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by salty-horse - 2018-05-05
Last edited by Bilgus - 2020-05-18

FS#13157 - Resuming opus after shutdown plays a second from the beginning before seeking

Tested on latest git master, on Sansa e200 and simulator. May affect other devices.

1) Play an opus file. Seek to the middle.
2) Shut down the device, and boot it up again.
3) Choose “Resume playback”.

Results:

A second from the beginning of the file will play before jumping to where playback was stopped when the device was shut down.

Closed by  Bilgus
2020-05-18 20:06
Reason for closing:  Works For Me
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Unable to reproduce

This only seems to happen with files encoded with ffmpeg.

For example, this file plays back fine:

https://opus-codec.org/static/examples/samples/music_128kbps.opus

but causes a problem when I re-encode it withffmpeg 3.4.2-2 using the command:

ffmpeg -i music_128kbps.opus -acodec libopus out.opus

Does this still occur with the latest dev builds?

Yes. Tested with latest master ed724fecb1 in the simulator.

can you upload the file that fails somewhere please?

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

This only happens with some opus files I download from youtube using youtube-dl with the “-x” flag.
Here’s a file where the skip I described consistently happens: https://www.dropbox.com/s/dwdczlqb0qsxmdu/JonGetsGames_Impressions_Vlog_July_2019.opus?dl=1

Ok tested this file on the fuze+ and in fuze+ sim couldn’t reproduce what target sim are you using?

I use the same target sim as my device, Sansa e200.
Step 2 (shutting down the device - or restarting the simulator) is important. If you just go to the home screen and resume it will work as expected.

Can you try with the file you posted?

steps I took.
made a new simulator for e200
make && make install
copied file to simdisk root
opened sim played file for 30secs fast forwarded to 30 MINUTES
hit close on simulator
opened sim scrolled to Resume playback
file starts at 30 mins no beginning of track heard just picks up where it left off

Tried to repeat the process on a different computer, and could not reproduce the issue.

Please give me a few days to run more tests before closing this.

no problem I won’t close till we can confirm one way or another

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing