Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#13167 : Rockbox does not play .webm OPUS files

Rockbox

Tasklist

FS#13167 - Rockbox does not play .webm OPUS files

Attached to Project: Rockbox
Opened by Adolf Hitler (hitlernigger) - Sunday, 13 January 2019, 18:11 GMT
Last edited by MichaelGiacomelli (saratoga) - Friday, 25 January 2019, 04:14 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System All players
Severity High
Priority Normal
Reported Version Release 3.14
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a lot of OPUS files as OGG OPUS and WEBM OPUS. Rockbox plays OPUS files that are in OGG container, but it cannot play OPUS files inside WEBM container.

I get WEBM OPUS files when I steal music from youtube using youtube-dl https://yt-dl.org
I can play them on my PC in any player (fb2k, MPC-HC), but cannot play them on ROCKBOX.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Friday, 25 January 2019, 04:14 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  There is no support for webm in rockbox.
Comment by Adolf Hitler (hitlernigger) - Sunday, 13 January 2019, 18:16 GMT
The files that I have are sound only. But it would be nice if ROCKBOX could play also the ones that have VP7/8/9 video. You can display video on LCD screen or throw it away.

I am attaching example of .WEBM OPUS.
Comment by Adolf Hitler (hitlernigger) - Sunday, 13 January 2019, 18:19 GMT
If you want to get more files like this you can use https://yt-dl.org as:
youtube-dl YOUTUBE_URL -f 251
this will steal 160kbps webm opus

youtube-dl YOUTUBE_URL -f 250
this will steal 70kbps webm opus

Loading...