Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Notice: A non well formed numeric value encountered in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 96 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.flyspray.php on line 104 Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /sites/rockbox.org/flyspray/adodb/adodb.inc.php on line 845 Deprecated: Function create_function() is deprecated in /sites/rockbox.org/flyspray/includes/class.user.php on line 111 FS#13182 : RockBox Utility 1.4.1 not running with Windows XP

Rockbox

Tasklist

FS#13182 - RockBox Utility 1.4.1 not running with Windows XP

Attached to Project: Rockbox
Opened by Gwen (E-Gwen) - Saturday, 16 November 2019, 17:21 GMT
Task Type Bugs
Category Operating System/Drivers
Status Unconfirmed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Rbutil SVN
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Hi,

When I try to install RockBox Utility 1.4.1 with Windows XP, i get this error message :

"the procedure entry point Direct3DCreate9Ex could not be located in the dynamic link library d3d9.dll"

Notice that RockBox Utility 1.4.0 is running fine.

Could you fix that bug with this new version ?

Best regards.

E-Gwen.
This task depends upon

Comment by Dominik Riebeling (bluebrother) - Saturday, 16 November 2019, 18:28 GMT
I don't consider this a bug.

It is built using a newer toolchain that targets Windows 7 and up. Since Windows XP had its end of life in 2014 (over 3 years ago) I don't think we should / have a need to support that anymore. Please use a current OS.

Or, if you really need, you can still build it yourself for XP on Windows XP.
Comment by Gwen (E-Gwen) - Saturday, 16 November 2019, 19:14 GMT
All right, sorry.

It's just that Windows XP and Windows 2000 is mentionned with this 1.4.1 version on its download page.

Well, I don't know how to build an executable file, but it would have been with pleasure.

So, will I be able to install RockBox 3.15 with RockBox Utility 1.4.0, or not ?

Thanks.
Comment by Dominik Riebeling (bluebrother) - Saturday, 16 November 2019, 20:38 GMT
1. Well, that wiki page is out of date then. I guess nobody checked the binary on older Windows versions, since (I guess) nobody uses those anymore.
2. Why don't you just try? Nothing bad will happen :)
You can install Rockbox 3.15 with the old Rockbox Utility. Main changes (see the changelog on the wiki page):
- fix a bug in autodetection that could crash Rockbox Utility
- Ipod 6G changes: support installing the bootloader and move it out of the "disabled target" section.

In the future please try our support channels first (IRC, forums, mailing list). Thanks.

(and obviously I can't do math -- 2014 is 5 years ago, not 3 ;-) )

Loading...