Rockbox

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Another
  • Severity Medium
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Johannes Rauh - 2020-05-08

FS#13196 - Xduoo X3ii: album art doesn't show for some jpgs in contrast to other players

I store the album art by putting a folder.jpg file in the album's directory.
Any WPS on other players shows the cover pictures properly if album art is enabled in the theme.

I am aware of caveats like progressive jpgs, that are not supported by RB.

In the attached zip file, there are four directories with a folder.jpg file and a free opus file for demonstration purposes.

All pictures show up fine on my Sansa E200 (v1) using CabbieV2 or lebellium_Samsung-like.
However, on my XduOO x3ii the pictures are not displayed for the examples 1 - 3, but show for example 4.

None of the jpgs are progressive and I cannot figure out a difference between 1-3 and 4.

I don't know how to debug this further myself, but would be happy doing any furter experiments.

This is true for the current dev builds, e.g. b450707955.

Johannes Rauh commented on 2020-05-29 19:57

A user in the forum found that AA is displayed if "folder" has a lowercase "f":
https://forums.rockbox.org/index.php/topic,52485.msg246272.html#msg246272

Johannes Rauh commented on 2020-05-29 20:00

I am sorry for spelling it already lowercase in the description above. All my other AA is Folder.jpg and it works with other players.

Johannes Rauh commented on 2020-07-17 14:44

The reason seems to be that on hosted targets (linux) the album art file name is case sensitive.
I need to find the code to change it and accept both Folder and folder.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing