Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Applications
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Critical
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by AndyP - 2020-07-10
Last edited by Solomon Peachy - 2020-07-11

FS#13213 - Patch 2466 - 'Try mounting as "superfloppy" first' breaks iPods 5G, 4G, nano 1G

Current git build fails to run on 4G, 4G Mini, 5G and Nano 1G ipods.

Rockbox boots but reports an error as ‘installation incomplete’ and no theme is loaded, no database is found and if you go into ‘Files’, no files are found and you cannot write any data to disk (dump identify_info).

Removing this patch and rebuilding allows the above iPods to boot and function normally.

6G Classic and 2G Nano’s do not appear to be affected.

Mini2G-8GB has a CF card fitted
Mini2G-16GBuSD has a uSD card fitted in an uSD-SD adapter in a SD-CF adapter.
All others are stock.

Closed by  Solomon Peachy
2020-07-11 23:14
Reason for closing:  Fixed
Additional comments about closing:  

Committed as 7249fab

Admin
Solomon Peachy commented on 2020-07-10 22:16

Can you dump the first few KB of the drive (via disk mode) so we can see what's going on?

(I have a theory.. it might be bunnies..)

Admin
Solomon Peachy commented on 2020-07-10 22:18

also, what's the content of settings/debug/partition info

Admin
Solomon Peachy commented on 2020-07-10 22:24

Finally, any dumps need full hw details – exact model, storage particulars (for the non-nano unit anyway)

FWIW I've using git HEAD with a mini2g with no issues.

Admin
Solomon Peachy commented on 2020-07-11 15:08

Thanks for the dumps. It looks like the problem has to do with the partition layout, namely the presence of multiple partitions.

(I think the underlying root cause is the removal of the partition type id check rather than mount order issues)

AndyP commented on 2020-07-11 20:19

Just done the following with a 4G Color,
Write 0's to first 2GB.
Connect to PC and restore with iTunes.
iPod boots and plays OK
Use Rockbox Utility V1.4.1 to install Rockbox.
Reboot.
Rockbox starts, reports 'No .rockbox directory' and 'installation incomplete'.
Select 'File', no files found. No music available.
Reboot into Apple OS.
iPod plays OK. Rockbox doesn't.

Admin
Solomon Peachy commented on 2020-07-11 20:25

Try applying this patch:

https://gerrit.rockbox.org/2523

AndyP commented on 2020-07-11 20:48

Tried on a 4G Color and appears to work OK.
Will try on the others

Admin
Solomon Peachy commented on 2020-07-11 21:42

I updated the patch after you reported success, can you reconfirm with the latest iteration?

AndyP commented on 2020-07-11 22:15

Patch 48ac569 causes 'No partition found. Insert USB cable and fix it' on a Mini1G.
Patch 6b2190f worked on all targets.

Admin
Solomon Peachy commented on 2020-07-11 22:40

Thank you! I've reverted to the older version.

AndyP commented on 2020-07-11 23:01

Patch 5 (7249fabe63) works on Mini1G, Nano1G, Mini2G,4G Grescale, 4G Color, Video 5G.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing