Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System xDuoo X3ii
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Rockbox
Opened by Ori Avtalion - 2020-08-07
Last edited by Solomon Peachy - 2020-10-12

FS#13229 - xDuoo X3ii - distortion when starting playback

Using daily build 89c7a4e393-200807 downloaded from the website.

Whenever I start playback of media, and sometimes when I pause-then-play during playback, I hear a short “screech” distortion.
I have tested this with mp3 and opus files.

This my first time using the device, so I can’t comment on whether it’s a regression.
My previous device was Sansa e200, and I never had this issue.

Closed by  Solomon Peachy
2020-10-12 23:23
Reason for closing:  Fixed
Additional comments about closing:  

I'm going to treat this as fixed. Small audio glitches when seeking or skipping tracks manually is not something unique to the X3ii; the PCM stream is being force-stopped and restarted.

In the mean time, I think the X3ii is as good as it's going to get for the forseeable future.

iMpig commented on 2020-09-25 12:14

I can confirm I'm hearing the "screech" sound on playback start as well. I'm on "daily build 1f9e16e".

Admin
Solomon Peachy commented on 2020-10-01 17:09

Please try this with the latest development build; I might have fixed this in the process of taking care of another issue.

(either the latest dev build, or the nightly build for 2020-10-02, which won't be created until late tonight)

Ori Avtalion commented on 2020-10-01 20:36

No more screeching, but now seeking is broken.

iMpig commented on 2020-10-02 09:24

I installed the b5cb99a7bf build.

* The very first time I tried playing a song (worked) and stopping it, no other song (including the same one) would play again until I restarted. Could not recreate this afterwards.

* I did hear a "pop" once while pressing play, otherwise OK

* Did not have any problems with seeking.

I only tested for a few minutes.

iMpig commented on 2020-10-02 09:27

Now there's a loud "pop" when powering on the unit. I can't remember if this was so before the update…

iMpig commented on 2020-10-02 09:31

And the "will not play" problem described above is back, seems to appear randomly (after a STOP maybe), reboot solves it.

Sorry about the comment spam.

iMpig commented on 2020-10-03 08:04

It looks like what I'm describing in comments above is filed under " FS#13231 " as a bug already.

iMpig commented on 2020-10-05 16:50

After some time, and a new dev build 74258fca31, my conclusion regarding distortion on play is:

* if a user skips to the next track (with "next" button) there will likely (maybe not always) be a short "pop" sound at the beginning of the new track.
PS: I tested this with a single flac file (whole album) + cuesheet, as well as separate flac track files.

* if user does not skip forawrd, but the next track plays as a result of the previous one ending there will be no "pop" sound.

Admin
Solomon Peachy commented on 2020-10-05 23:13

The underlying problem in both the startup "pop" and the click/glitch between some tracks is due to the DAC resetting, switching modes, or even simply going in or out of power saving mode.

The CorrectWay™ to work around this is to mute the analog audio path. The problem is that, due to how xDuoo implemented things, it takes over a second to switch. As we can't unmute until *after* the codec is configured and PCM playback has started, this results in us losing the first second of audio output.

I should be able to work around the initial pop at system startup, but when it comes to audio pops/clicks between tracks (or simply adjusting the volume when nothing is playing) losing the first second of sound is not considered acceptable. (especially when voice prompts are in use)

another option is to leave the codec always playing silence, but we would still have a pop/click occur when switching to a different playback sample rate. (eg Mp3 on one track to high-resolution FLAC on another).

So there is no good solution.

iMpig commented on 2020-10-06 06:49

Thank you for the detailed explanation and your work on this!

The last options seems interesting since one could avoid the pops by simply having the music encoded the same way - if I understand this correctly.

Admin
Solomon Peachy commented on 2020-10-12 15:50

Commit 68857536 should behave a lot better on the x3ii (should be out of the build farm in ~30 minutes)

* The really nasty startup pop is gone
* Most audio glitching on playback pause/resume/track change is gone
* Lose the first second(ish) of the first PCM played after startup

iMpig commented on 2020-10-12 20:36

Great work Solomon Peachy!
I can confirm everything but the "track change" bit - that still has a bit of a crunchy sound. But much much better now, thank you very much!

iMpig commented on 2020-10-12 20:43

With "track change" I meant pressing a button to skip to the next track (or just to fast forward). It's not a problem when tracks change on their own.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing