Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Database
  • Assigned To No-one
  • Operating System iPod Mini
  • Severity Medium
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by J - 2020-08-10
Last edited by Solomon Peachy - 2020-08-26

FS#13230 - Specific mp3 causes the database creation/update to crash.

Daily build 2020-08-10 Ipod Mini 2nd Gen

This mp3 causes the database creation/update to crash gives error:

Data abort at 00050210
pc:00050210 sp:000dbd30
A: 0005041c
A: 000503fc
A: 0005069c
A: 00050eb0
bt end

I used MP3 Scan + Repair and it had no issues with the file. Checked the tags to see if there was anything crazy, nothing seems off about the file. It’s in an album of 22 songs and this is the only which caused an error.
I also redownloaded the file from the source to see if it wasn’t complete.

Closed by  Solomon Peachy
2020-08-26 22:51
Reason for closing:  Not a Bug
Additional comments about closing:  

Since neither of us can recreate it.. I'm going to close this.

J commented on 2020-08-11 14:30

Also seeing the same error with these files.
Seems like it doesn't like Kanye.

Admin
Solomon Peachy commented on 2020-08-24 19:36

I haven't been able to trigger this on other players, but I happen to have a mini2g that I will try later tonight.

Admin
Solomon Peachy commented on 2020-08-24 19:47

I can't recreate this on my mini2g either, using the latest git code (c7cbd494eb)

I wonder if the problem is due to a slightly-corrupted database on your player? Have you tried deleting it on disk and/or re-initializing it?

J commented on 2020-08-26 22:17

I'm actually not sure what the issue was. But I think this was more of a generic issue either with the SD card or iPod itself. It did seem to be these files as it could not initialise the database as it would completely crash when it got to these files. But I was having the occasional sad iPod on boot.
Since tried the latest rockbox on a different iPod and it's working perfectly so far.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing