Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System xDuoo X3
  • Severity Medium
  • Priority Medium
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date 2020-09-24
    32 days overdue
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Zachary Keel - 2020-08-29
Last edited by Willliam W - 2020-09-24

FS#13237 - xDuoo X3: Headphone jack related settings not working

Tested with build a2b77446c2 on two devices, has been present for longer (unsure if this is a regression).
The specific settings that I have noticed not working are the following:

Pause on headphone unplug:
Audio will not pause if it was playing when the headphones are unplugged no matter what it is set to; if set to ‘Pause and Resume’ it also does not resume when headphones are plugged back in.

Disable resume on startup if no headphones plugged:
This almost works. If nothing is plugged in when the device is started, it starts paused. If Line Out has something plugged into it and the device is powered on, it resumes. If something is plugged into the headphone jack and the device is powered on, it will start paused and on the Quick Menu (I have mine set to start on the WPS, the other two situations respect this).

Closed by  Willliam W
2020-09-24 17:54
Reason for closing:  Fixed
Admin
Solomon Peachy commented on 2020-08-29 19:14

I'm not able to recreate the 'pause on headphone unplug' thing with the current code (3dc4f81).

Can you retest now, please?

Zachary Keel commented on 2020-08-29 22:22

I updated to 3dc4f81 and tried again, but 'pause on headphone unplug' still was not working properly on either X3 that I tested.
Something I noticed: when said setting is set to 'Pause', it does pause whenever I unplug Line Out (but not the headphone jack). Setting it to 'Pause and Resume' neither pauses nor resumes when plugging in or unplugging either output jack.

Admin
Solomon Peachy commented on 2020-08-29 22:38

I set mine to pause+unause, and it worked as expected with the 3dc4f81 build, plugging/unplugging the headphones. (nothing was in the line out jack)

So.. I don't know what to say at this point…

Admin
Solomon Peachy commented on 2020-08-29 22:41

there are two known hardware variations, although there is no known way to identify them in software.

Does yours have a button labeled 'ESC' on it?

Zachary Keel commented on 2020-08-31 00:28

No, neither of mine have a button labeled ESC. I looked up an image of it, the button that would be 'ESC' is labeled as 'BACK' underneath the button with a pictogram of a house above it.

Were you able to reproduce the problem I described with 'Disable resume on startup if no headphones plugged' on your X3?

Admin
Solomon Peachy commented on 2020-09-10 02:58

In the last couple of days more work has gone into the button code – including the headphone jack detection that had false positives. Can you retest on your unit with the latest nightly or dev build?

Zachary Keel commented on 2020-09-10 11:34

I updated to 14c2f55ab3 (September 10), but it doesn't seem fixed.
Pause on headphone unplug still does nothing. Disable resume on startup if no headphones plugged isn't working, and now it doesn't resume if something is plugged into Line Out either.

Willliam W commented on 2020-09-15 18:12

you might try renaming your .rockbox directory and starting fresh from the latest dev build

be sure to remember to set headphone pause / resume

I'm getting flawless pause\resume on the HP port its not so great on LO though its about 75%
if you can verify the HP part works for you now I'll try something similar with LO

Zachary Keel commented on 2020-09-18 01:08

I updated to the 2020-09-17 build (2df3a5b04c), new .rockbox folder.
After enabling it, 'pause and resume on headphone unplug' works all the time for LO but never for the headphones.
Also, 'disable resume on startup if no headphones plugged' doesn't seem to work for either LO or headphones (it starts paused no matter what is plugged in).

Willliam W commented on 2020-09-20 01:45

the headphone one sounds like a HW issue do you see status of HP plug unplug in the debug menu under 'IO ports'

Zachary Keel commented on 2020-09-20 02:06

With nothing plugged in, the line labelled GPIOB has a value of eff077fc. Plugging in LO changes it to eff067fc. Plugging in the headphones doesn't seem to change it.
Could I just have terrible luck and both of them arrived with broken headphone detection? I just tested the original OS and it doesn't seem to pause on unplug for headphones either.

Willliam W commented on 2020-09-20 18:52

there is an actual entry for HP and LO click next till you see it
that is a mirror of the input the detection code uses to make a decision

edit: if you don't see it there either its on a different GPIO on your unit and or broken

Zachary Keel commented on 2020-09-20 21:13

Sorry, I was unaware.
It shows my headphones as removed no matter what is plugged into it, but it does detect LO fine. I tried looking at the other GPIO values as I plugged and unplugged the headphone port, but none of them seemed to be affected by it.

Willliam W commented on 2020-09-22 06:29

Unfortunately it sounds like you have a faulty headphone port ot someone forgot the sense pin
have you tried another set of headphones?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing